cComboAdd Method

Adds a new load combination.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int Add(
	string Name,
	int ComboType
)

Parameters

Name
Type: SystemString
The name of a new load combination.
ComboType
Type: SystemInt32
This is 0, 1, 2, 3 or 4 indicating the load combination type.
  • 0 = Linear Additive
  • 1 = Envelope
  • 2 = Absolute Additive
  • 3 = SRSS
  • 4 = Range Additive

Return Value

Type: Int32
Returns zero if the load combination is successfully added, otherwise it returns a nonzero value.
Remarks
The new load combination must have a different name from all other load combinations and all load cases. If the name is not unique, an error will be returned.
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add combo
       ret = SapModel.RespCombo.Add("COMB1", 1)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also