cPropFrameSetAutoSelectSteel Method |
Assigns frame section properties to an auto select list. If this function is called for an
existing frame section property, all items for the section are reset to their default value.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetAutoSelectSteel(
string Name,
int NumberItems,
ref string[] SectName,
string AutoStartSection = "Median",
string Notes = "",
string GUID = ""
)
Function SetAutoSelectSteel (
Name As String,
NumberItems As Integer,
ByRef SectName As String(),
Optional AutoStartSection As String = "Median",
Optional Notes As String = "",
Optional GUID As String = ""
) As Integer
int SetAutoSelectSteel(
String^ Name,
int NumberItems,
array<String^>^% SectName,
String^ AutoStartSection = L"Median",
String^ Notes = L"",
String^ GUID = L""
)
abstract SetAutoSelectSteel :
Name : string *
NumberItems : int *
SectName : string[] byref *
?AutoStartSection : string *
?Notes : string *
?GUID : string
(* Defaults:
let _AutoStartSection = defaultArg AutoStartSection "Median"
let _Notes = defaultArg Notes ""
let _GUID = defaultArg GUID ""
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing or new frame section property.
If this is an existing property, that property is modified; otherwise, a new property is added.
- NumberItems
- Type: SystemInt32
The number of frame section properties included in the auto select list.
- SectName
- Type: SystemString
This is an array of the names of the frame section properties included in the auto select list.
Auto select lists and nonprismatic (variable) sections are not allowed in this array.
- AutoStartSection (Optional)
- Type: SystemString
This is either Median or the name of a frame section property
in the SectName array. It is the starting section for the auto select list.
- Notes (Optional)
- Type: SystemString
The notes, if any, assigned to the section.
- GUID (Optional)
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the section.
If this item is input as Default, the program assigns a GUID to the section.
Return Value
Type:
Int32Returns zero if the auto select list is successfully filled;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim MyName() As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.SetAngle("ANGLE1", "A992Fy50", 6, 4, 0.5, 0.5)
ret = SapModel.PropFrame.SetAngle("ANGLE2", "A992Fy50", 5, 3, 0.4, 0.4)
ret = SapModel.PropFrame.SetAngle("ANGLE3", "A992Fy50", 4, 2, 0.3, 0.3)
ReDim MyName(2)
MyName(0) = "ANGLE1"
MyName(1) = "ANGLE2"
MyName(2) = "ANGLE3"
ret = SapModel.PropFrame.SetAutoSelectSteel("AUTO1", 3, MyName, "ANGLE2")
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also