cPropAreaSetWallAutoSelectList Method |
Namespace: ETABS2016
int SetWallAutoSelectList( string Name, string[] AutoSelectList, string StartingProperty = "Median" )
Median indicates the Median Property by Thickness
Public Sub Example() Dim SapModel As cSapModel Dim EtabsObject As cOAPI Dim ret As Integer = -1 Dim WallPropType As eWallPropType Dim ShellType As eShellType Dim MatProp As String Dim Thickness As Double Dim Color As Integer Dim Notes As String Dim GUID As String Dim AutoSelectList As String() Dim StartingProp As String 'create ETABS object EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject") 'start ETABS application ret = EtabsObject.ApplicationStart() 'create SapModel object SapModel = EtabsObject.SapModel 'initialize model ret = SapModel.InitializeNewModel() 'create steel deck template model ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24) 'set new area property ret = SapModel.PropArea.SetWall("MyShellProp1A", eWallPropType.Specified, eShellType.ShellThick, "4000Psi", 11.1) 'set new area property ret = SapModel.PropArea.SetWall("MyShellProp1B", eWallPropType.Specified, eShellType.ShellThin, "4000Psi", 12.2) 'set new area property ret = SapModel.PropArea.SetWall("MyShellProp1C", eWallPropType.AutoSelectList, eShellType.ShellThick, "4000Psi", 13.3) 'set new area property ret = SapModel.PropArea.SetWall("MyShellProp1D", eWallPropType.AutoSelectList, eShellType.ShellThick, "4000Psi", 14.4) 'set new area property Dim tmpList As String() ReDim tmpList(2) tmpList(0) = "MyShellProp1A" tmpList(1) = "MyShellProp1B" tmpList(2) = "MyShellProp1C" ret = SapModel.PropArea.SetWallAutoSelectList("MyShellProp1D", tmpList, "MyShellProp1B") 'get area property data ret = SapModel.PropArea.GetWall("MyShellProp1D", WallPropType, ShellType, MatProp, Thickness, Color, Notes, GUID) 'get area property data ret = SapModel.PropArea.GetWallAutoSelectList("MyShellProp1D", AutoSelectList, StartingProp) 'close ETABS EtabsObject.ApplicationExit(False) 'clean up variables SapModel = Nothing EtabsObject = Nothing End Sub