cAnalysisResultsFrameForce Method |
Reports the frame forces for the specified line elements
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint FrameForce(
string Name,
eItemTypeElm ItemTypeElm,
ref int NumberResults,
ref string[] Obj,
ref double[] ObjSta,
ref string[] Elm,
ref double[] ElmSta,
ref string[] LoadCase,
ref string[] StepType,
ref double[] StepNum,
ref double[] P,
ref double[] V2,
ref double[] V3,
ref double[] T,
ref double[] M2,
ref double[] M3
)
Function FrameForce (
Name As String,
ItemTypeElm As eItemTypeElm,
ByRef NumberResults As Integer,
ByRef Obj As String(),
ByRef ObjSta As Double(),
ByRef Elm As String(),
ByRef ElmSta As Double(),
ByRef LoadCase As String(),
ByRef StepType As String(),
ByRef StepNum As Double(),
ByRef P As Double(),
ByRef V2 As Double(),
ByRef V3 As Double(),
ByRef T As Double(),
ByRef M2 As Double(),
ByRef M3 As Double()
) As Integer
int FrameForce(
String^ Name,
eItemTypeElm ItemTypeElm,
int% NumberResults,
array<String^>^% Obj,
array<double>^% ObjSta,
array<String^>^% Elm,
array<double>^% ElmSta,
array<String^>^% LoadCase,
array<String^>^% StepType,
array<double>^% StepNum,
array<double>^% P,
array<double>^% V2,
array<double>^% V3,
array<double>^% T,
array<double>^% M2,
array<double>^% M3
)
abstract FrameForce :
Name : string *
ItemTypeElm : eItemTypeElm *
NumberResults : int byref *
Obj : string[] byref *
ObjSta : float[] byref *
Elm : string[] byref *
ElmSta : float[] byref *
LoadCase : string[] byref *
StepType : string[] byref *
StepNum : float[] byref *
P : float[] byref *
V2 : float[] byref *
V3 : float[] byref *
T : float[] byref *
M2 : float[] byref *
M3 : float[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing line object, line element or group of objects,
depending on the value of the ItemTypeElm item.
- ItemTypeElm
- Type: ETABS2016eItemTypeElm
This is one of the following items in the eItemTypeElm
enumeration.
If this item is ObjectElm, the result request is for the line elements
corresponding to the line object specified by the Name item.
If this item is Element, the result request is for the line
element specified by the Name item.
If this item is GroupElm, the result request is for the line elements
corresponding to all line objects included in the group specified by the Name item.
If this item is SelectionElm, the result request is for line elements
corresponding to all selected line objects and the Name item is ignored.
- NumberResults
- Type: SystemInt32
The total number of results returned by the program
- Obj
- Type: SystemString
This is an array that includes the line object name associated with each result, if any
- ObjSta
- Type: SystemDouble
This is an array that includes the distance measured from the I-end of the line object to the result location
- Elm
- Type: SystemString
This is an array that includes the line element name associated with each result
- ElmSta
- Type: SystemDouble
This is an array that includes the distance measured from the I-end of the line element to the result location
- LoadCase
- Type: SystemString
This is an array that includes the name of the analysis case or load combination associated with each result
- StepType
- Type: SystemString
This is an array that includes the step type, if any, for each result
- StepNum
- Type: SystemDouble
This is an array that includes the step number, if any, for each result
- P
- Type: SystemDouble
This is a one dimensional array of the axial force for each result. [F]
- V2
- Type: SystemDouble
This is a one dimensional array of the shear force in the local 2 direction for each result. [F]
- V3
- Type: SystemDouble
This is a one dimensional array of the shear force in the local 3 direction for each result. [F]
- T
- Type: SystemDouble
This is a one dimensional array of the torsion for each result. [FL]
- M2
- Type: SystemDouble
This is a one dimensional array of the moment about the local 2-axis for each result. [FL]
- M3
- Type: SystemDouble
This is a one dimensional array of the moment about the local 3-axis for each result. [FL]
Return Value
Type:
Int32
Returns zero if the forces are successfully recovered, otherwise it returns a nonzero value
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim NumberResults As Integer
Dim Obj() As String
Dim ObjSta() As Double
Dim Elm() As String
Dim ElmSta() As Double
Dim LoadCase() As String
Dim StepType() As String
Dim StepNum() As Double
Dim P() As Double
Dim V2() As Double
Dim V3() As Double
Dim T() As Double
Dim M2() As Double
Dim M3() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
System.IO.Directory.CreateDirectory("c:\CSI_API_temp")
ret = SapModel.File.Save("C:\CSI_API_temp\example.edb")
ret = SapModel.Analyze.RunAnalysis()
ret = SapModel.Results.Setup.DeselectAllCasesAndCombosForOutput()
ret = SapModel.Results.Setup.SetCaseSelectedForOutput("DEAD")
ret = mySapModel.Results.FrameForce("1", eItemTypeElm.ObjectElm, NumberResults, Obj, ObjSta, Elm, ElmSta, LoadCase, StepType, StepNum, P, V2, V3, T, M2, M3)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also