cPointObjSetSpring Method |
Assigns coupled springs to a point object.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetSpring(
string Name,
ref double[] K,
eItemType ItemType = eItemType.Objects,
bool IsLocalCSys = true,
bool Replace = false
)
Function SetSpring (
Name As String,
ByRef K As Double(),
Optional ItemType As eItemType = eItemType.Objects,
Optional IsLocalCSys As Boolean = true,
Optional Replace As Boolean = false
) As Integer
int SetSpring(
String^ Name,
array<double>^% K,
eItemType ItemType = eItemType::Objects,
bool IsLocalCSys = true,
bool Replace = false
)
abstract SetSpring :
Name : string *
K : float[] byref *
?ItemType : eItemType *
?IsLocalCSys : bool *
?Replace : bool
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
let _IsLocalCSys = defaultArg IsLocalCSys true
let _Replace = defaultArg Replace false
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing point object or group depending on the value
of the ItemType item.
- K
- Type: SystemDouble
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Object, the spring assignment is made to the point object
specified by the Name item.
If this item is Group, the spring assignment is made to all point objects
in the group specified by the Name item.
If this item is SelectedObjects, the spring assignment is made to all
selected point objects and the Name item is ignored.
- IsLocalCSys (Optional)
- Type: SystemBoolean
If this item is True, the specified spring assignments are in the
point object local coordinate system. If it is False, the assignments
are in the Global coordinate system.
- Replace (Optional)
- Type: SystemBoolean
If this item is True, all existing point spring assignments to the specified
point object(s) are deleted prior to making the assignment. If it is False,
the spring assignments are added to any existing assignments.
Return Value
Type:
Int32
Returns zero if the stiffnesses are successfully assigned,
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ReDim k(5)
k(2) = 10
ret = SapModel.PointObj.SetSpring("3", k)
ReDim k(5)
ret = SapModel.PointObj.GetSpring("3", k)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also