cPropAreaGetSlabWaffle Method |
Namespace: ETABS2016
int GetSlabWaffle( string Name, ref double OverallDepth, ref double SlabThickness, ref double StemWidthTop, ref double StemWidthBot, ref double RibSpacingDir1, ref double RibSpacingDir2 )
Public Sub Example() Dim SapModel As cSapModel Dim EtabsObject As cOAPI Dim ret As Integer = -1 Dim SlabType As eSlabType Dim ShellType As eShellType Dim MatProp As String Dim Thickness As Double Dim Color As Integer Dim Notes As String Dim GUID As String Dim OverallDepth As Double Dim SlabThickness As Double Dim StemWidthTop As Double Dim StemWidthBot As Double Dim RibSpacing1 As Double Dim RibSpacing2 As Double 'create ETABS object EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject") 'start ETABS application ret = EtabsObject.ApplicationStart() 'create SapModel object SapModel = EtabsObject.SapModel 'initialize model ret = SapModel.InitializeNewModel() 'create steel deck template model ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24) 'set new area property ret = SapModel.PropArea.SetSlab("MyShellProp1A", eSlabType.Waffle, eShellType.ShellThin, "4000Psi", 14.2) 'set new area property ret = SapModel.PropArea.SetSlabWaffle(Name:="MyShellProp1A", OverallDepth:=11.1, SlabThickness:=22.2, StemWidthTop:=33.3, StemWidthBot:=44.4, RibSpacingDir1:=55.5, RibSpacingDir2:=66.6) 'get area property data ret = SapModel.PropArea.GetSlab("MyShellProp1A", SlabType, ShellType, MatProp, Thickness, Color, Notes, GUID) 'get area property data ret = SapModel.PropArea.GetSlabWaffle("MyShellProp1A", OverallDepth, SlabThickness, StemWidthTop, StemWidthBot, RibSpacing1, RibSpacing2) 'close ETABS EtabsObject.ApplicationExit(False) 'clean up variables SapModel = Nothing EtabsObject = Nothing End Sub