cFrameObjGetEndLengthOffset Method |
Retrieves the frame object end offsets along the 1-axis of the object.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetEndLengthOffset(
string Name,
ref bool AutoOffset,
ref double Length1,
ref double Length2,
ref double RZ
)
Function GetEndLengthOffset (
Name As String,
ByRef AutoOffset As Boolean,
ByRef Length1 As Double,
ByRef Length2 As Double,
ByRef RZ As Double
) As Integer
int GetEndLengthOffset(
String^ Name,
bool% AutoOffset,
double% Length1,
double% Length2,
double% RZ
)
abstract GetEndLengthOffset :
Name : string *
AutoOffset : bool byref *
Length1 : float byref *
Length2 : float byref *
RZ : float byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame object.
- AutoOffset
- Type: SystemBoolean
If this item is True, the end length offsets are automatically
determined by the program from object connectivity.
- Length1
- Type: SystemDouble
- Length2
- Type: SystemDouble
- RZ
- Type: SystemDouble
The rigid zone factor. This is the fraction of the end offset length
assumed to be rigid for bending and shear deformations.
Return Value
Type:
Int32
Returns zero if the offsets are successfully retrieved,
otherwise it returns a nonzero value.
Remarks
See Also