cPointObjDeleteSpring Method

Deletes all point spring assignments from the specified point object(s).

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int DeleteSpring(
	string Name,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: SystemString
The name of an existing point object or group depending on the value of the ItemType item.
ItemType (Optional)
Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If Objects is selected, the Name item refers to a point object. The point spring assignments for that point object are removed.

If Group is selected, the Name item refers to a group. The point spring assignments for all point objects in the group are removed.

If SelectedObjects is selected, the Name item is ignored. The point spring assignments for all selected point objects are removed.

Return Value

Type: Int32
Returns zero if the restraint assignments are successfully deleted, otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim i as Integer
       Dim k as Double()

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

   'add joint spring assignment
       Redim k(5)
       For i = 0 to 5
           k(i) = i + 1
       Next i
       ret = SapModel.PointObj.SetSpring("3", k)

   'delete joint spring assignment
       ret = SapModel.PointObj.DeleteSpring("3")

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also