cComboDeleteCase Method

Deletes one load case or load combination from the list of cases included in the specified load combination.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int DeleteCase(
	string Name,
	eCNameType CNameType,
	string CName
)

Parameters

Name
Type: SystemString
The name of an existing load combination.
CNameType
Type: ETABS2016eCNameType
This is one of the following items in the eCNameType enumeration:
  • LoadCase = 0
  • LoadCombo = 1

This item indicates whether the CName item is an analysis case (LoadCase) or a load combination (LoadCombo).

CName
Type: SystemString
The name of the load case or load combination to be deleted from the specified combination.

Return Value

Type: Int32
Returns zero if the item is successfully deleted, otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add combo
       ret = SapModel.RespCombo.Add("COMB1", 0)

   'add load case to combo
       ret = SapModel.RespCombo.SetCaseList("COMB1", LoadCase, "DEAD", 1.4)

   'delete load case from combo
       ret = SapModel.RespCombo.DeleteCase("COMB1", LoadCase, "DEAD")

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also