cFrameObjSetTCLimits Method |
Makes tension/compression force limit assignments to frame objects.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetTCLimits(
string Name,
bool LimitCompressionExists,
double LimitCompression,
bool LimitTensionExists,
double LimitTension,
eItemType ItemType = eItemType.Objects
)
Function SetTCLimits (
Name As String,
LimitCompressionExists As Boolean,
LimitCompression As Double,
LimitTensionExists As Boolean,
LimitTension As Double,
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int SetTCLimits(
String^ Name,
bool LimitCompressionExists,
double LimitCompression,
bool LimitTensionExists,
double LimitTension,
eItemType ItemType = eItemType::Objects
)
abstract SetTCLimits :
Name : string *
LimitCompressionExists : bool *
LimitCompression : float *
LimitTensionExists : bool *
LimitTension : float *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing frame object or group depending on the value
of the ItemType item.
- LimitCompressionExists
- Type: SystemBoolean
This item is True if a compression force limit exists for the frame object.
- LimitCompression
- Type: SystemDouble
The compression force limit for the frame object. [F]
- LimitTensionExists
- Type: SystemBoolean
This item is True if a tension force limit exists for the frame object.
- LimitTension
- Type: SystemDouble
The tension force limit for the frame object. [F]
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignment is made to the frame object
specified by the Name item.
If this item is Group, the assignment is made to all frame objects
in the group specified by the Name item.
If this item is SelectedObjects, the assignment is made to all
selected frame objects and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the assignments are successfully applied,
otherwise it returns a nonzero value.
Remarks
Note that the tension and compression limits are only used
in nonlinear analyses.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj.SetTCLimits("1", False, 0, True, 100)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also