cGridSysGetGridSysCylindrical Method |
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetGridSysCylindrical(
string Name,
ref double Xo,
ref double Yo,
ref double RZ,
ref bool StoryRangeIsDefault,
ref string TopStory,
ref string BottomStory,
ref double BubbleSize,
ref int GridColor,
ref int NumRLines,
ref string[] GridLineIDR,
ref double[] OrdinateR,
ref bool[] VisibleR,
ref string[] BubbleLocR,
ref int NumTLines,
ref string[] GridLineIDT,
ref double[] OrdinateT,
ref bool[] VisibleT,
ref string[] BubbleLocT
)
Function GetGridSysCylindrical (
Name As String,
ByRef Xo As Double,
ByRef Yo As Double,
ByRef RZ As Double,
ByRef StoryRangeIsDefault As Boolean,
ByRef TopStory As String,
ByRef BottomStory As String,
ByRef BubbleSize As Double,
ByRef GridColor As Integer,
ByRef NumRLines As Integer,
ByRef GridLineIDR As String(),
ByRef OrdinateR As Double(),
ByRef VisibleR As Boolean(),
ByRef BubbleLocR As String(),
ByRef NumTLines As Integer,
ByRef GridLineIDT As String(),
ByRef OrdinateT As Double(),
ByRef VisibleT As Boolean(),
ByRef BubbleLocT As String()
) As Integer
int GetGridSysCylindrical(
String^ Name,
double% Xo,
double% Yo,
double% RZ,
bool% StoryRangeIsDefault,
String^% TopStory,
String^% BottomStory,
double% BubbleSize,
int% GridColor,
int% NumRLines,
array<String^>^% GridLineIDR,
array<double>^% OrdinateR,
array<bool>^% VisibleR,
array<String^>^% BubbleLocR,
int% NumTLines,
array<String^>^% GridLineIDT,
array<double>^% OrdinateT,
array<bool>^% VisibleT,
array<String^>^% BubbleLocT
)
abstract GetGridSysCylindrical :
Name : string *
Xo : float byref *
Yo : float byref *
RZ : float byref *
StoryRangeIsDefault : bool byref *
TopStory : string byref *
BottomStory : string byref *
BubbleSize : float byref *
GridColor : int byref *
NumRLines : int byref *
GridLineIDR : string[] byref *
OrdinateR : float[] byref *
VisibleR : bool[] byref *
BubbleLocR : string[] byref *
NumTLines : int byref *
GridLineIDT : string[] byref *
OrdinateT : float[] byref *
VisibleT : bool[] byref *
BubbleLocT : string[] byref -> int
Parameters
- Name
- Type: SystemString
- Xo
- Type: SystemDouble
- Yo
- Type: SystemDouble
- RZ
- Type: SystemDouble
- StoryRangeIsDefault
- Type: SystemBoolean
- TopStory
- Type: SystemString
- BottomStory
- Type: SystemString
- BubbleSize
- Type: SystemDouble
- GridColor
- Type: SystemInt32
- NumRLines
- Type: SystemInt32
- GridLineIDR
- Type: SystemString
- OrdinateR
- Type: SystemDouble
- VisibleR
- Type: SystemBoolean
- BubbleLocR
- Type: SystemString
- NumTLines
- Type: SystemInt32
- GridLineIDT
- Type: SystemString
- OrdinateT
- Type: SystemDouble
- VisibleT
- Type: SystemBoolean
- BubbleLocT
- Type: SystemString
Return Value
Type:
Int32
See Also