cPropFrameImportProp Method |
Imports a frame section property from a property file.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint ImportProp(
string Name,
string MatProp,
string FileName,
string PropName,
int Color = -1,
string Notes = "",
string GUID = ""
)
Function ImportProp (
Name As String,
MatProp As String,
FileName As String,
PropName As String,
Optional Color As Integer = -1,
Optional Notes As String = "",
Optional GUID As String = ""
) As Integer
int ImportProp(
String^ Name,
String^ MatProp,
String^ FileName,
String^ PropName,
int Color = -1,
String^ Notes = L"",
String^ GUID = L""
)
abstract ImportProp :
Name : string *
MatProp : string *
FileName : string *
PropName : string *
?Color : int *
?Notes : string *
?GUID : string
(* Defaults:
let _Color = defaultArg Color -1
let _Notes = defaultArg Notes ""
let _GUID = defaultArg GUID ""
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing or new frame section property.
If this is an existing property, that property is modified;
otherwise, a new property is added. This name does not need
to be the same as the PropName item.
- MatProp
- Type: SystemString
The name of the material property for the section.
- FileName
- Type: SystemString
The name of the frame section property file from which to get
the frame section property specified by the PropName item.
In most cases you can input just the name of the property file
(e.g. "AISC14.xml") and the program will be able to find it.
In some cases you may have to input the full path to the property file.
- PropName
- Type: SystemString
The name of the frame section property, inside the property file specified
by the FileName item, that is to be imported.
- Color (Optional)
- Type: SystemInt32
- Notes (Optional)
- Type: SystemString
- GUID (Optional)
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the section.
If this item is input as Default, the program assigns a GUID to the section.
Return Value
Type:
Int32
Returns zero if the section property is successfully initialized;
otherwise it returns a nonzero value.
Remarks
If the property file is not found, or the specified property name
is not found in the property file, the section is set to be a general
section with default properties.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.ImportProp("W18X35", "A992Fy50", "Sections8.pro", "W18X35")
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also