cFrameObjGetAllFrames Method |
Retrieves select data for all frame objects in the model
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetAllFrames(
ref int NumberNames,
ref string[] MyName,
ref string[] PropName,
ref string[] StoryName,
ref string[] PointName1,
ref string[] PointName2,
ref double[] Point1X,
ref double[] Point1Y,
ref double[] Point1Z,
ref double[] Point2X,
ref double[] Point2Y,
ref double[] Point2Z,
ref double[] Angle,
ref double[] Offset1X,
ref double[] Offset2X,
ref double[] Offset1Y,
ref double[] Offset2Y,
ref double[] Offset1Z,
ref double[] Offset2Z,
ref int[] CardinalPoint,
string csys = "Global"
)
Function GetAllFrames (
ByRef NumberNames As Integer,
ByRef MyName As String(),
ByRef PropName As String(),
ByRef StoryName As String(),
ByRef PointName1 As String(),
ByRef PointName2 As String(),
ByRef Point1X As Double(),
ByRef Point1Y As Double(),
ByRef Point1Z As Double(),
ByRef Point2X As Double(),
ByRef Point2Y As Double(),
ByRef Point2Z As Double(),
ByRef Angle As Double(),
ByRef Offset1X As Double(),
ByRef Offset2X As Double(),
ByRef Offset1Y As Double(),
ByRef Offset2Y As Double(),
ByRef Offset1Z As Double(),
ByRef Offset2Z As Double(),
ByRef CardinalPoint As Integer(),
Optional csys As String = "Global"
) As Integer
int GetAllFrames(
int% NumberNames,
array<String^>^% MyName,
array<String^>^% PropName,
array<String^>^% StoryName,
array<String^>^% PointName1,
array<String^>^% PointName2,
array<double>^% Point1X,
array<double>^% Point1Y,
array<double>^% Point1Z,
array<double>^% Point2X,
array<double>^% Point2Y,
array<double>^% Point2Z,
array<double>^% Angle,
array<double>^% Offset1X,
array<double>^% Offset2X,
array<double>^% Offset1Y,
array<double>^% Offset2Y,
array<double>^% Offset1Z,
array<double>^% Offset2Z,
array<int>^% CardinalPoint,
String^ csys = L"Global"
)
abstract GetAllFrames :
NumberNames : int byref *
MyName : string[] byref *
PropName : string[] byref *
StoryName : string[] byref *
PointName1 : string[] byref *
PointName2 : string[] byref *
Point1X : float[] byref *
Point1Y : float[] byref *
Point1Z : float[] byref *
Point2X : float[] byref *
Point2Y : float[] byref *
Point2Z : float[] byref *
Angle : float[] byref *
Offset1X : float[] byref *
Offset2X : float[] byref *
Offset1Y : float[] byref *
Offset2Y : float[] byref *
Offset1Z : float[] byref *
Offset2Z : float[] byref *
CardinalPoint : int[] byref *
?csys : string
(* Defaults:
let _csys = defaultArg csys "Global"
*)
-> int
Parameters
- NumberNames
- Type: SystemInt32
- MyName
- Type: SystemString
- PropName
- Type: SystemString
- StoryName
- Type: SystemString
- PointName1
- Type: SystemString
- PointName2
- Type: SystemString
- Point1X
- Type: SystemDouble
- Point1Y
- Type: SystemDouble
- Point1Z
- Type: SystemDouble
- Point2X
- Type: SystemDouble
- Point2Y
- Type: SystemDouble
- Point2Z
- Type: SystemDouble
- Angle
- Type: SystemDouble
- Offset1X
- Type: SystemDouble
- Offset2X
- Type: SystemDouble
- Offset1Y
- Type: SystemDouble
- Offset2Y
- Type: SystemDouble
- Offset1Z
- Type: SystemDouble
- Offset2Z
- Type: SystemDouble
- CardinalPoint
- Type: SystemInt32
- csys (Optional)
- Type: SystemString
Return Value
Type:
Int32
Remarks
See Also