cAnalyzeModifyUndeformedGeometry Method

Modifies the undeformed geometry based on displacements obtained from a specified load case

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int ModifyUndeformedGeometry(
	string CaseName,
	double SF,
	int Stage = -1,
	bool Original = false
)

Parameters

CaseName
Type: SystemString
SF
Type: SystemDouble
Stage (Optional)
Type: SystemInt32
This item applies only when the specified load case is a staged construction load case. It is the stage number from which the displacements are obtained. Specifying a -1 for this item means to use the last run stage.
Original (Optional)
Type: SystemBoolean
If this item is True, all other input items in this function are ignored and the original undeformed geometry data is reinstated.

Return Value

Type: Int32
Returns zero if it is successful; otherwise it returns a nonzero value
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'assign point object restraints
       ReDim Value(5)
       For i = 0 To 5
           Value(i) = True
       Next i
       ret = SapModel.PointObj.SetRestraint("1", Value)

   'run analysis
       System.IO.Directory.CreateDirectory("c:\CSI_API_temp")
       ret = SapModel.File.Save("C:\CSI_API_temp\example.edb")
       ret = SapModel.Analyze.RunAnalysis

   'modify undeformed geometry
       ret = SapModel.Analyze.ModifyUndeformedGeometry("DEAD", 1)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also