cAnalysisResultsLinkForce Method |
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint LinkForce(
string Name,
eItemTypeElm ItemTypeElm,
ref int NumberResults,
ref string[] Obj,
ref string[] Elm,
ref string[] PointElm,
ref string[] LoadCase,
ref string[] StepType,
ref double[] StepNum,
ref double[] P,
ref double[] V2,
ref double[] V3,
ref double[] T,
ref double[] M2,
ref double[] M3
)
Function LinkForce (
Name As String,
ItemTypeElm As eItemTypeElm,
ByRef NumberResults As Integer,
ByRef Obj As String(),
ByRef Elm As String(),
ByRef PointElm As String(),
ByRef LoadCase As String(),
ByRef StepType As String(),
ByRef StepNum As Double(),
ByRef P As Double(),
ByRef V2 As Double(),
ByRef V3 As Double(),
ByRef T As Double(),
ByRef M2 As Double(),
ByRef M3 As Double()
) As Integer
int LinkForce(
String^ Name,
eItemTypeElm ItemTypeElm,
int% NumberResults,
array<String^>^% Obj,
array<String^>^% Elm,
array<String^>^% PointElm,
array<String^>^% LoadCase,
array<String^>^% StepType,
array<double>^% StepNum,
array<double>^% P,
array<double>^% V2,
array<double>^% V3,
array<double>^% T,
array<double>^% M2,
array<double>^% M3
)
abstract LinkForce :
Name : string *
ItemTypeElm : eItemTypeElm *
NumberResults : int byref *
Obj : string[] byref *
Elm : string[] byref *
PointElm : string[] byref *
LoadCase : string[] byref *
StepType : string[] byref *
StepNum : float[] byref *
P : float[] byref *
V2 : float[] byref *
V3 : float[] byref *
T : float[] byref *
M2 : float[] byref *
M3 : float[] byref -> int
Parameters
- Name
- Type: SystemString
- ItemTypeElm
- Type: ETABS2016eItemTypeElm
- NumberResults
- Type: SystemInt32
- Obj
- Type: SystemString
- Elm
- Type: SystemString
- PointElm
- Type: SystemString
- LoadCase
- Type: SystemString
- StepType
- Type: SystemString
- StepNum
- Type: SystemDouble
- P
- Type: SystemDouble
- V2
- Type: SystemDouble
- V3
- Type: SystemDouble
- T
- Type: SystemDouble
- M2
- Type: SystemDouble
- M3
- Type: SystemDouble
Return Value
Type:
Int32
See Also