cLoadPatternsSetLoadType Method

Assigns a load type to a load pattern.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetLoadType(
	string Name,
	eLoadPatternType MyType
)

Parameters

Name
Type: SystemString
The name of an existing load pattern.
MyType
Type: ETABS2016eLoadPatternType
This is one of the items in the eLoadPatternType enumeration.

Return Value

Type: Int32
Returns zero if the load type is successfully assigned; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim MyType As eLoadPatternType

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'assign load type
       ret = SapModel.LoadPatterns.SetLoadType("DEAD", eLoadPatternType.SuperDead)

   'get load pattern type
       ret = SapModel.LoadPatterns.GetLoadType("DEAD", MyType)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also