cFrameObjSetReleases Method |
Makes end release and partial fixity assignments to frame objects.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetReleases(
string Name,
ref bool[] II,
ref bool[] JJ,
ref double[] StartValue,
ref double[] EndValue,
eItemType ItemType = eItemType.Objects
)
Function SetReleases (
Name As String,
ByRef II As Boolean(),
ByRef JJ As Boolean(),
ByRef StartValue As Double(),
ByRef EndValue As Double(),
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int SetReleases(
String^ Name,
array<bool>^% II,
array<bool>^% JJ,
array<double>^% StartValue,
array<double>^% EndValue,
eItemType ItemType = eItemType::Objects
)
abstract SetReleases :
Name : string *
II : bool[] byref *
JJ : bool[] byref *
StartValue : float[] byref *
EndValue : float[] byref *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing frame object or group, depending on the
value of the ItemType item.
- II
- Type: SystemBoolean
- JJ
- Type: SystemBoolean
These is an array of six booleans indicating the J-End
releases for the frame object.
- ii(0) and jj(0) = U1 release
- ii(1) and jj(1) = U2 release
- ii(2) and jj(2) = U3 release
- ii(3) and jj(3) = R1 release
- ii(4) and jj(4) = R2 release
- ii(5) and jj(5) = R3 release
- StartValue
- Type: SystemDouble
These is an array of six values indicating the I-End
partial fixity springs for the frame object.
- StartValue(0) and EndValue(0) = U1 partial fixity [F/L]
- StartValue(1) and EndValue(1) = U2 partial fixity [F/L]
- StartValue(2) and EndValue(2) = U3 partial fixity [F/L]
- StartValue(3) and EndValue(3) = R1 partial fixity [FL/rad]
- StartValue(4) and EndValue(4) = R2 partial fixity [FL/rad]
- StartValue(5) and EndValue(5) = R3 partial fixity [FL/rad]
- EndValue
- Type: SystemDouble
These is an array of six values indicating the J-End
partial fixity springs for the frame object.
- StartValue(0) and EndValue(0) = U1 partial fixity [F/L]
- StartValue(1) and EndValue(1) = U2 partial fixity [F/L]
- StartValue(2) and EndValue(2) = U3 partial fixity [F/L]
- StartValue(3) and EndValue(3) = R1 partial fixity [FL/rad]
- StartValue(4) and EndValue(4) = R2 partial fixity [FL/rad]
- StartValue(5) and EndValue(5) = R3 partial fixity [FL/rad]
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignment is made to the frame object
specified by the Name item.
If this item is Group, the assignment is made to all frame objects
in the group specified by the Name item.
If this item is SelectedObjects, the assignment is made to all
selected frame objects and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the assignments are successfully retrieved,
otherwise it returns a nonzero value.
Remarks
Partial fixity assignments are made to degrees of freedom
that have been released only.
Some release assignments would cause instability in the model.
An error is returned if this type of assignment is made.
Unstable release assignments include the following:
- U1 released at both ends
- U2 released at both ends
- U3 released at both ends
- R1 released at both ends
- R2 released at both ends and U3 at either end
- R3 released at both ends and U2 at either end
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim ii() As Boolean
Dim jj() As Boolean
Dim StartValue() As Double
Dim EndValue() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ReDim ii(5)
ReDim jj(5)
ReDim StartValue(5)
ReDim EndValue(5)
ii(5) = True
jj(5) = True
ret = SapModel.FrameObj.SetReleases("13", ii, jj, StartValue, EndValue)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also