cPointObjSetGUID Method

Sets the GUID for specified point object. If the GUID is passed in as a blank string, the program automatically creates a GUID for the object.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetGUID(
	string Name,
	string GUID = ""
)

Parameters

Name
Type: SystemString
The name of an existing point object.
GUID (Optional)
Type: SystemString
The GUID (Global Unique ID) for the specified point object.

Return Value

Type: Int32
Returns zero if the point object GUID is successfully set; otherwise it returns nonzero.
Remarks
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1
   Dim GUID As String

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

'create steel deck template model
   ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'set program created GUID
   ret = SapModel.PointObj.SetGUID("1")

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also