cLoadPatternsGetAutoWindCode Method

Retrieves the code name used for auto wind parameters in Wind-type load patterns.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetAutoWindCode(
	string Name,
	ref string CodeName
)

Parameters

Name
Type: SystemString
The name of an existing Wind-type load pattern.
CodeName
Type: SystemString
This is either blank or the name code used for the auto wind parameters. Blank means no auto wind load is specified for the Wind-type load pattern.

Return Value

Type: Int32
Returns zero if the code is successfully retrieved; otherwise it returns a nonzero value.
Remarks
An error is returned if the specified load pattern is not a Wind-type load pattern.
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim CodeName As String

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add new load pattern
       ret = SapModel.LoadPatterns.Add("WIND", LTYPE_WIND)

   'get auto wind code
       ret = SapModel.LoadPatterns.GetAutoWindCode("WIND", CodeName)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also