cFrameObjSetLoadDistributed Method |
Assigns distributed loads to frame objects.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetLoadDistributed(
string Name,
string LoadPat,
int MyType,
int Dir,
double Dist1,
double Dist2,
double Val1,
double Val2,
string CSys = "Global",
bool RelDist = true,
bool Replace = true,
eItemType ItemType = eItemType.Objects
)
Function SetLoadDistributed (
Name As String,
LoadPat As String,
MyType As Integer,
Dir As Integer,
Dist1 As Double,
Dist2 As Double,
Val1 As Double,
Val2 As Double,
Optional CSys As String = "Global",
Optional RelDist As Boolean = true,
Optional Replace As Boolean = true,
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int SetLoadDistributed(
String^ Name,
String^ LoadPat,
int MyType,
int Dir,
double Dist1,
double Dist2,
double Val1,
double Val2,
String^ CSys = L"Global",
bool RelDist = true,
bool Replace = true,
eItemType ItemType = eItemType::Objects
)
abstract SetLoadDistributed :
Name : string *
LoadPat : string *
MyType : int *
Dir : int *
Dist1 : float *
Dist2 : float *
Val1 : float *
Val2 : float *
?CSys : string *
?RelDist : bool *
?Replace : bool *
?ItemType : eItemType
(* Defaults:
let _CSys = defaultArg CSys "Global"
let _RelDist = defaultArg RelDist true
let _Replace = defaultArg Replace true
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing frame object or group, depending on the
value of the ItemType item.
- LoadPat
- Type: SystemString
The name of a defined load pattern.
- MyType
- Type: SystemInt32
This is 1 or 2, indicating the type of distributed load.
- Force per unit length
- Moment per unit length
- Dir
- Type: SystemInt32
This is an integer between 1 and 11, indicating the direction of the load.
- Local 1 axis (only applies when CSys is Local)
- Local 2 axis (only applies when CSys is Local)
- Local 3 axis (only applies when CSys is Local)
- X direction (does not apply when CSys is Local)
- Y direction (does not apply when CSys is Local)
- Z direction (does not apply when CSys is Local)
- Projected X direction (does not apply when CSys is Local)
- Projected Y direction (does not apply when CSys is Local)
- Projected Z direction (does not apply when CSys is Local)
- Gravity direction (only applies when CSys is Global)
- Projected Gravity direction (only applies when CSys is Global)
The positive gravity direction (see Dir = 10 and 11) is in
the negative Global Z direction.
- Dist1
- Type: SystemDouble
This is the distance from the I-End of the frame object to the start
of the distributed load. This may be a relative distance
(0 <= Dist1 <= 1) or an actual distance, depending on the
value of the RelDist item. [L] when
RelDist is False
- Dist2
- Type: SystemDouble
This is the distance from the J-End of the frame object to the start
of the distributed load. This may be a relative distance
(0 <= Dist2 <= 1) or an actual distance, depending on the
value of the RelDist item. [L] when
RelDist is False
- Val1
- Type: SystemDouble
This is the load value at the start of the distributed load.
[F/L] when MyType is 1 and [FL/L] when
MyType is 2
- Val2
- Type: SystemDouble
This is the load value at the end of the distributed load.
[F/L] when MyType is 1 and [FL/L] when
MyType is 2
- CSys (Optional)
- Type: SystemString
This is Local or the name of a defined coordinate system.
It is the coordinate system in which the loads are specified.
- RelDist (Optional)
- Type: SystemBoolean
If this item is True, the specified Dist item is a relative distance,
otherwise it is an actual distance.
- Replace (Optional)
- Type: SystemBoolean
If this item is True, all previous loads, if any,
assigned to the specified frame object(s), in the specified load pattern,
are deleted before making the new assignment.
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignment is made to the frame object
specified by the Name item.
If this item is Group, the assignment is made to all frame objects
in the group specified by the Name item.
If this item is SelectedObjects, the assignment is made to all
selected frame objects and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the loads are successfully assigned,
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj.SetLoadDistributed("15", "DEAD", 1, 10, 0, 1, 0.08, 0.08)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also