cPropAreaGetNameList Method

Retrieves the names of all defined area properties of the specified type.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetNameList(
	ref int NumberNames,
	ref string[] MyName,
	int PropType = 0
)

Parameters

NumberNames
Type: SystemInt32
The number of area property names retrieved by the program.
MyName
Type: SystemString
One-dimensional array of area property names. The MyName array is created as a dynamic, zero-based, array by the API user:

Dim MyName() as String

The array is dimensioned to (NumberNames - 1) inside the program, filled with the names, and returned to the API user.
PropType (Optional)
Type: SystemInt32
This optional value is 0, 1, 2 or 3, indicating the type of area properties included in the name list.
ValueType
0All
1Shell
2Plane
3Asolid

Return Value

Type: Int32
Returns zero if the names are successfully retrieved; otherwise it returns nonzero
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim i As Integer
       Dim NumberNames As Integer
       Dim MyName() As String

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'get area property names
       ret = SapModel.PropArea.GetNameList(NumberNames, MyName)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also