cPointObjSetRestraint Method

Assigns the restraint assignments for a point object. The restraint assignments are always set in the point local coordinate system.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetRestraint(
	string Name,
	ref bool[] Value,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: SystemString
The name of an existing point object or group depending on the value of the ItemType item.
Value
Type: SystemBoolean
This is an array of six restraint values.
  • Value(0) = U1
  • Value(1) = U2
  • Value(2) = U3
  • Value(3) = R1
  • Value(4) = R2
  • Value(5) = R3
ItemType (Optional)
Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the restraint assignment is made to the point object specified by the Name item.

If this item is Group, the restraint assignment is made to all point objects in the group specified by the Name item.

If this item is SelectedObjects, the restraint assignment is made to all selected point objects and the Name item is ignored.

Return Value

Type: Int32
Returns zero if the restraint assignments are successfully assigned, otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim Value as Boolean()

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

   'assign point object restraints
       ReDim Value(5)
       For i = 0 To 5
           Value(i) = True
       Next i
       ret = SapModel.PointObj.SetRestraint("1", Value)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also