cPropFrameGetAllFrameProperties Method |
Retrieves select data for all frame properties in the model
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetAllFrameProperties(
ref int NumberNames,
ref string[] MyName,
ref eFramePropType[] PropType,
ref double[] t3,
ref double[] t2,
ref double[] tf,
ref double[] tw,
ref double[] t2b,
ref double[] tfb
)
Function GetAllFrameProperties (
ByRef NumberNames As Integer,
ByRef MyName As String(),
ByRef PropType As eFramePropType(),
ByRef t3 As Double(),
ByRef t2 As Double(),
ByRef tf As Double(),
ByRef tw As Double(),
ByRef t2b As Double(),
ByRef tfb As Double()
) As Integer
int GetAllFrameProperties(
int% NumberNames,
array<String^>^% MyName,
array<eFramePropType>^% PropType,
array<double>^% t3,
array<double>^% t2,
array<double>^% tf,
array<double>^% tw,
array<double>^% t2b,
array<double>^% tfb
)
abstract GetAllFrameProperties :
NumberNames : int byref *
MyName : string[] byref *
PropType : eFramePropType[] byref *
t3 : float[] byref *
t2 : float[] byref *
tf : float[] byref *
tw : float[] byref *
t2b : float[] byref *
tfb : float[] byref -> int
Parameters
- NumberNames
- Type: SystemInt32
- MyName
- Type: SystemString
- PropType
- Type: ETABS2016eFramePropType
- t3
- Type: SystemDouble
- t2
- Type: SystemDouble
- tf
- Type: SystemDouble
- tw
- Type: SystemDouble
- t2b
- Type: SystemDouble
- tfb
- Type: SystemDouble
Return Value
Type:
Int32
Remarks
See Also