cPropFrameGetCoverPlatedI Method

retrieves frame section property data for a cover plated I-type frame section.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetCoverPlatedI(
	string Name,
	ref string SectName,
	ref double FyTopFlange,
	ref double FyWeb,
	ref double FyBotFlange,
	ref double Tc,
	ref double Bc,
	ref string MatPropTop,
	ref double Tcb,
	ref double Bcb,
	ref string MatPropBot,
	ref int Color,
	ref string Notes,
	ref string GUID
)

Parameters

Name
Type: SystemString
The name of an existing frame section property.
SectName
Type: SystemString
FyTopFlange
Type: SystemDouble
The yield strength of the top flange of the I-section. [F/L2]

If this item is 0, the yield strength of the I-section specified by the SectName item is used.

FyWeb
Type: SystemDouble
The yield strength of the web of the I-section. [F/L2]

If this item is 0, the yield strength of the I-section specified by the SectName item is used.

FyBotFlange
Type: SystemDouble
The yield strength of the bottom flange of the I-section. [F/L2]

If this item is 0, the yield strength of the I-section specified by the SectName item is used.

Tc
Type: SystemDouble
Bc
Type: SystemDouble
MatPropTop
Type: SystemString
The name of the material property for the bottom cover plate.

This item applies only if both the tcb and the bcb items are greater than 0.

Tcb
Type: SystemDouble
Bcb
Type: SystemDouble
MatPropBot
Type: SystemString
The name of the material property for the bottom cover plate.

This item applies only if both the tcb and the bcb items are greater than 0.

Color
Type: SystemInt32
Notes
Type: SystemString
GUID
Type: SystemString
The GUID (global unique identifier), if any, assigned to the section.

Return Value

Type: Int32
Returns zero if the section property is successfully initialized; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim SectName As String
       Dim FyTopFlange As Double
       Dim FyWeb As Double
       Dim FyBotFlange As Double
       Dim tc As Double
       Dim bc As Double
       Dim MatPropTop As String
       Dim tcb As Double
       Dim bcb As Double
       Dim MatPropBot As String
       Dim Color As Integer
       Dim Notes As String
       Dim GUID As String


   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'set new I-type frame section property
       ret = SapModel.PropFrame.SetISection("ISEC", "A992Fy50", 24, 8, 0.5, 0.3, 8, 0.5)

   'set new cover plated I-type frame section property
       ret = SapModel.PropFrame.SetCoverPlatedI("CPI1", "ISEC", 0, 36, 0, 0.75, 14, "A992Fy50", 0.5, 6, "A992Fy50")

   'get frame section property data for cover plated I
       ret = SapModel.PropFrame.GetCoverPlatedI("CPI1", SectName, FyTopFlange, FyWeb, FyBotFlange, tc, bc, MatPropTop, tcb, bcb, MatPropBot, Color, Notes, GUID)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also