cFrameObjGetLoadPoint Method |
Retrieves the point load assignments to frame objects.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetLoadPoint(
string Name,
ref int NumberItems,
ref string[] FrameName,
ref string[] LoadPat,
ref int[] MyType,
ref string[] CSys,
ref int[] Dir,
ref double[] RelDist,
ref double[] Dist,
ref double[] Val,
eItemType ItemType = eItemType.Objects
)
Function GetLoadPoint (
Name As String,
ByRef NumberItems As Integer,
ByRef FrameName As String(),
ByRef LoadPat As String(),
ByRef MyType As Integer(),
ByRef CSys As String(),
ByRef Dir As Integer(),
ByRef RelDist As Double(),
ByRef Dist As Double(),
ByRef Val As Double(),
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int GetLoadPoint(
String^ Name,
int% NumberItems,
array<String^>^% FrameName,
array<String^>^% LoadPat,
array<int>^% MyType,
array<String^>^% CSys,
array<int>^% Dir,
array<double>^% RelDist,
array<double>^% Dist,
array<double>^% Val,
eItemType ItemType = eItemType::Objects
)
abstract GetLoadPoint :
Name : string *
NumberItems : int byref *
FrameName : string[] byref *
LoadPat : string[] byref *
MyType : int[] byref *
CSys : string[] byref *
Dir : int[] byref *
RelDist : float[] byref *
Dist : float[] byref *
Val : float[] byref *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing frame object or group, depending on the
value of the ItemType item.
- NumberItems
- Type: SystemInt32
The total number of point loads retrieved for the specified frame objects.
- FrameName
- Type: SystemString
This is an array that includes the name of the frame object associated
with each point load.
- LoadPat
- Type: SystemString
This is an array that includes the name of the load pattern associated
with each point load.
- MyType
- Type: SystemInt32
This is an array that includes 1 or 2, indicating the type of point load.
- Force
- Moment
- CSys
- Type: SystemString
This is an array that includes the name of the coordinate system
in which each point load is defined.
It may be Local or the name of a defined coordinate system.
- Dir
- Type: SystemInt32
This is an integer between 1 and 11, indicating the direction of the load.
- Local 1 axis (only applies when CSys is Local)
- Local 2 axis (only applies when CSys is Local)
- Local 3 axis (only applies when CSys is Local)
- X direction (does not apply when CSys is Local)
- Y direction (does not apply when CSys is Local)
- Z direction (does not apply when CSys is Local)
- Projected X direction (does not apply when CSys is Local)
- Projected Y direction (does not apply when CSys is Local)
- Projected Z direction (does not apply when CSys is Local)
- Gravity direction (only applies when CSys is Global)
- Projected Gravity direction (only applies when CSys is Global)
The positive gravity direction (see Dir = 10 and 11) is in
the negative Global Z direction.
- RelDist
- Type: SystemDouble
This is an array that includes the relative distance from the I-End
of the frame object to the location where the point load is applied.
- Dist
- Type: SystemDouble
- Val
- Type: SystemDouble
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignments are retrieved for the frame object
specified by the Name item.
If this item is Group, the assignments are retrieved for all frame objects
in the group specified by the Name item.
If this item is SelectedObjects, the assignments are retrieved for all
selected frame objects and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the load assignments are successfully retrieved,
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim NumberItems As Integer
Dim FrameName() As String
Dim LoadPat() As String
Dim MyType() As Integer
Dim CSys() As String
Dim Dir() As Integer
Dim RelDist() As Double
Dim Dist() As Double
Dim Val() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj.SetLoadPoint("14", "DEAD", 1, 10, .5, 20)
ret = SapModel.FrameObj.SetLoadPoint("15", "DEAD", 1, 10, .5, 20)
ret = SapModel.FrameObj.GetLoadPoint("ALL", NumberItems, FrameName, LoadPat, MyType, CSys, Dir, RelDist, Dist, Val, Group)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also