cPropFrameSetConcreteTee Method |
Initializes a concrete tee frame section property. If this function is called for an existing
frame section property, all items for the section are reset to their default value.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetConcreteTee(
string Name,
string MatProp,
double T3,
double T2,
double Tf,
double TwF,
double TwT,
bool MirrorAbout3,
int Color = -1,
string Notes = "",
string GUID = ""
)
Function SetConcreteTee (
Name As String,
MatProp As String,
T3 As Double,
T2 As Double,
Tf As Double,
TwF As Double,
TwT As Double,
MirrorAbout3 As Boolean,
Optional Color As Integer = -1,
Optional Notes As String = "",
Optional GUID As String = ""
) As Integer
int SetConcreteTee(
String^ Name,
String^ MatProp,
double T3,
double T2,
double Tf,
double TwF,
double TwT,
bool MirrorAbout3,
int Color = -1,
String^ Notes = L"",
String^ GUID = L""
)
abstract SetConcreteTee :
Name : string *
MatProp : string *
T3 : float *
T2 : float *
Tf : float *
TwF : float *
TwT : float *
MirrorAbout3 : bool *
?Color : int *
?Notes : string *
?GUID : string
(* Defaults:
let _Color = defaultArg Color -1
let _Notes = defaultArg Notes ""
let _GUID = defaultArg GUID ""
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing or new frame section property.
If this is an existing property, that property is modified; otherwise, a new property is added. - MatProp
- Type: SystemString
The name of the material property for the section. - T3
- Type: SystemDouble
- T2
- Type: SystemDouble
- Tf
- Type: SystemDouble
- TwF
- Type: SystemDouble
The web thickness at the flange. [L] - TwT
- Type: SystemDouble
The web thickness at the tip. [L] - MirrorAbout3
- Type: SystemBoolean
Indicates whether the section is mirrored about the local 3-axis. - Color (Optional)
- Type: SystemInt32
- Notes (Optional)
- Type: SystemString
- GUID (Optional)
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the section.
If this item is input as Default, the program assigns a GUID to the section.
Return Value
Type:
Int32Returns zero if the section property is successfully initialized;
otherwise it returns a nonzero value.
Remarks
This function supersedes
SetTee(String, String, Double, Double, Double, Double, Int32, String, String).
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.SetConcreteTee("TEE1", "4000Psi", 30, 36, 8, 7, 5, False)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also