cPropFrameSDShapeGetReinfRectangular Method

Retrieves property data for a rectangular reinforcing shape in a section designer section

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetReinfRectangular(
	string Name,
	string ShapeName,
	ref double XCenter,
	ref double YCenter,
	ref double H,
	ref double W,
	ref double Rotation,
	ref string MatRebar
)

Parameters

Name
Type: SystemString
The name of an existing frame section property that is a section designer section
ShapeName
Type: SystemString
The name of a rectangular reinforcing shape in the section designer section
XCenter
Type: SystemDouble
The X-coordinate of the center of the shape in the section designer coordinate system. [L]
YCenter
Type: SystemDouble
The Y-coordinate of the center of the shape in the section designer coordinate system. [L]
H
Type: SystemDouble
The section depth. [L]
W
Type: SystemDouble
The top flange width. [L]
Rotation
Type: SystemDouble
The counter clockwise rotation of the shape from its default orientation. [deg
MatRebar
Type: SystemString
The material property for the reinforcing steel

Return Value

Type: Int32
Returns zero if the property data is successfully retrieved; otherwise it returns a nonzero value
Remarks