cGridSysGetGridSys_2 Method |
Retrieves the grid system specified by the Name item.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetGridSys_2(
string Name,
ref double Xo,
ref double Yo,
ref double RZ,
ref string GridSysType,
ref int NumXLines,
ref int NumYLines,
ref string[] GridLineIDX,
ref string[] GridLineIDY,
ref double[] OrdinateX,
ref double[] OrdinateY,
ref bool[] VisibleX,
ref bool[] VisibleY,
ref string[] BubbleLocX,
ref string[] BubbleLocY
)
Function GetGridSys_2 (
Name As String,
ByRef Xo As Double,
ByRef Yo As Double,
ByRef RZ As Double,
ByRef GridSysType As String,
ByRef NumXLines As Integer,
ByRef NumYLines As Integer,
ByRef GridLineIDX As String(),
ByRef GridLineIDY As String(),
ByRef OrdinateX As Double(),
ByRef OrdinateY As Double(),
ByRef VisibleX As Boolean(),
ByRef VisibleY As Boolean(),
ByRef BubbleLocX As String(),
ByRef BubbleLocY As String()
) As Integer
int GetGridSys_2(
String^ Name,
double% Xo,
double% Yo,
double% RZ,
String^% GridSysType,
int% NumXLines,
int% NumYLines,
array<String^>^% GridLineIDX,
array<String^>^% GridLineIDY,
array<double>^% OrdinateX,
array<double>^% OrdinateY,
array<bool>^% VisibleX,
array<bool>^% VisibleY,
array<String^>^% BubbleLocX,
array<String^>^% BubbleLocY
)
abstract GetGridSys_2 :
Name : string *
Xo : float byref *
Yo : float byref *
RZ : float byref *
GridSysType : string byref *
NumXLines : int byref *
NumYLines : int byref *
GridLineIDX : string[] byref *
GridLineIDY : string[] byref *
OrdinateX : float[] byref *
OrdinateY : float[] byref *
VisibleX : bool[] byref *
VisibleY : bool[] byref *
BubbleLocX : string[] byref *
BubbleLocY : string[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing grid system.
- Xo
- Type: SystemDouble
The global X grid of the origin of the grid system. [L]
- Yo
- Type: SystemDouble
The global Y grid of the origin of the grid system. [L]
- RZ
- Type: SystemDouble
The rotation of an axis of the new grid system relative to the
global grid system is defined as follows:
(1) Rotate the grid system about the positive global Z-axis
as defined by the RZ item. [deg]
- GridSysType
- Type: SystemString
- NumXLines
- Type: SystemInt32
- NumYLines
- Type: SystemInt32
- GridLineIDX
- Type: SystemString
- GridLineIDY
- Type: SystemString
- OrdinateX
- Type: SystemDouble
- OrdinateY
- Type: SystemDouble
- VisibleX
- Type: SystemBoolean
- VisibleY
- Type: SystemBoolean
- BubbleLocX
- Type: SystemString
- BubbleLocY
- Type: SystemString
Return Value
Type:
Int32
Returns zero if the grid system data is successfully retrieved,
otherwise it returns a nonzero value.
Remarks
Examples
See Also