cFrameObjSetSection Method

Assigns a frame section property to a frame object.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetSection(
	string Name,
	string PropName,
	eItemType ItemType = eItemType.Objects,
	double SVarRelStartLoc = 0,
	double SVarTotalLength = 0
)

Parameters

Name
Type: SystemString
The name of an existing frame object or group, depending on the value of the ItemType item.
PropName
Type: SystemString
This is None or the name of a frame section property to be assigned to the specified frame object(s).
ItemType (Optional)
Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the assignment is made to the frame object specified by the Name item.

If this item is Group, the assignment is made to all frame objects in the group specified by the Name item.

If this item is SelectedObjects, the assignment is made to all selected frame objects and the Name item is ignored.

SVarRelStartLoc (Optional)
Type: SystemDouble
SVarTotalLength (Optional)
Type: SystemDouble

Return Value

Type: Int32
Returns zero if the frame section property data is successfully assigned, otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

'create steel deck template model
   ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'create new concrete frame section property
   ret = SapModel.PropFrame.SetRectangle("R1", "4000Psi", 20, 12)

'set frame section property
   ret = SapModel.FrameObj.SetSection("8", "R1")

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also