cFrameObjAddByCoord Method |
Adds a new frame object whose end points are at the specified coordinates.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint AddByCoord(
double XI,
double YI,
double ZI,
double XJ,
double YJ,
double ZJ,
ref string Name,
string PropName = "Default",
string UserName = "",
string CSys = "Global"
)
Function AddByCoord (
XI As Double,
YI As Double,
ZI As Double,
XJ As Double,
YJ As Double,
ZJ As Double,
ByRef Name As String,
Optional PropName As String = "Default",
Optional UserName As String = "",
Optional CSys As String = "Global"
) As Integer
int AddByCoord(
double XI,
double YI,
double ZI,
double XJ,
double YJ,
double ZJ,
String^% Name,
String^ PropName = L"Default",
String^ UserName = L"",
String^ CSys = L"Global"
)
abstract AddByCoord :
XI : float *
YI : float *
ZI : float *
XJ : float *
YJ : float *
ZJ : float *
Name : string byref *
?PropName : string *
?UserName : string *
?CSys : string
(* Defaults:
let _PropName = defaultArg PropName "Default"
let _UserName = defaultArg UserName ""
let _CSys = defaultArg CSys "Global"
*)
-> int
Parameters
- XI
- Type: SystemDouble
The coordinates of the I-End of the added frame object.
The coordinates are in the coordinate system defined by
the CSys item.
- YI
- Type: SystemDouble
- ZI
- Type: SystemDouble
- XJ
- Type: SystemDouble
- YJ
- Type: SystemDouble
- ZJ
- Type: SystemDouble
- Name
- Type: SystemString
This is the name that the program ultimately assigns for the frame object.
If no userName is specified, the program assigns
a default name to the frame object. If a userName
is specified and that name is not used for another frame, cable
or tendon object, the userName is assigned
to the frame object, otherwise a default name is assigned to the frame object.
- PropName (Optional)
- Type: SystemString
This is Default, None, or the name of a defined frame section property.
If it is Default, the program assigns a default section property
to the frame object. If it is None, no section property is assigned
to the frame object. If it is the name of a defined frame section property,
that property is assigned to the frame object.
- UserName (Optional)
- Type: SystemString
- CSys (Optional)
- Type: SystemString
The name of the coordinate system in which the frame object
end point coordinates are defined.
Return Value
Type:
Int32
Returns zero if the frame object is successfully added,
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel(eUnits.lb_ft_F)
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj.AddByCoord(0, 72, 48, 0, 48, 36, Name)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also