Initializes a tube-type frame section property.
If this function is called for an existing frame section property,
all items for the section are reset to their default value.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetTube(
string Name,
string MatProp,
double T3,
double T2,
double Tf,
double Tw,
int Color = -1,
string Notes = "",
string GUID = ""
)
Function SetTube (
Name As String,
MatProp As String,
T3 As Double,
T2 As Double,
Tf As Double,
Tw As Double,
Optional Color As Integer = -1,
Optional Notes As String = "",
Optional GUID As String = ""
) As Integer
int SetTube(
String^ Name,
String^ MatProp,
double T3,
double T2,
double Tf,
double Tw,
int Color = -1,
String^ Notes = L"",
String^ GUID = L""
)
abstract SetTube :
Name : string *
MatProp : string *
T3 : float *
T2 : float *
Tf : float *
Tw : float *
?Color : int *
?Notes : string *
?GUID : string
(* Defaults:
let _Color = defaultArg Color -1
let _Notes = defaultArg Notes ""
let _GUID = defaultArg GUID ""
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing or new frame section property.
If this is an existing property, that property is modified;
otherwise, a new property is added.
- MatProp
- Type: SystemString
The name of the material property for the section.
- T3
- Type: SystemDouble
- T2
- Type: SystemDouble
- Tf
- Type: SystemDouble
- Tw
- Type: SystemDouble
- Color (Optional)
- Type: SystemInt32
- Notes (Optional)
- Type: SystemString
- GUID (Optional)
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the section.
If this item is input as Default, the program assigns a GUID to the section.
Return Value
Type:
Int32
Returns zero if the section property is successfully initialized; otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim FileName As String
Dim MatProp As String
Dim t3 As Double
Dim t2 As Double
Dim tf As Double
Dim tw As Double
Dim Color As Long
Dim Notes As String
Dim GUID As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.SetTube("TUBE1", "A992Fy50", 8, 6, 0.5, 0.5)
ret = SapModel.PropFrame.GetTube("TUBE1", FileName, MatProp, t3, t2, tf, tw, Color, Notes, GUID)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also