cAnalysisResultsBaseReact Method |
Reports the structure total base reactions
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint BaseReact(
ref int NumberResults,
ref string[] LoadCase,
ref string[] StepType,
ref double[] StepNum,
ref double[] FX,
ref double[] FY,
ref double[] FZ,
ref double[] MX,
ref double[] ParamMy,
ref double[] MZ,
ref double GX,
ref double GY,
ref double GZ
)
Function BaseReact (
ByRef NumberResults As Integer,
ByRef LoadCase As String(),
ByRef StepType As String(),
ByRef StepNum As Double(),
ByRef FX As Double(),
ByRef FY As Double(),
ByRef FZ As Double(),
ByRef MX As Double(),
ByRef ParamMy As Double(),
ByRef MZ As Double(),
ByRef GX As Double,
ByRef GY As Double,
ByRef GZ As Double
) As Integer
int BaseReact(
int% NumberResults,
array<String^>^% LoadCase,
array<String^>^% StepType,
array<double>^% StepNum,
array<double>^% FX,
array<double>^% FY,
array<double>^% FZ,
array<double>^% MX,
array<double>^% ParamMy,
array<double>^% MZ,
double% GX,
double% GY,
double% GZ
)
abstract BaseReact :
NumberResults : int byref *
LoadCase : string[] byref *
StepType : string[] byref *
StepNum : float[] byref *
FX : float[] byref *
FY : float[] byref *
FZ : float[] byref *
MX : float[] byref *
ParamMy : float[] byref *
MZ : float[] byref *
GX : float byref *
GY : float byref *
GZ : float byref -> int
Parameters
- NumberResults
- Type: SystemInt32
The total number of results returned by the program
- LoadCase
- Type: SystemString
This is an array that includes the name of the analysis case or load combination associated with each result
- StepType
- Type: SystemString
This is an array that includes the step type, if any, for each result
- StepNum
- Type: SystemDouble
This is an array that includes the step number, if any, for each result
- FX
- Type: SystemDouble
This array contains the base reaction force in the global X direction for each result. [F]
- FY
- Type: SystemDouble
This array contains the base reaction force in the global Y direction for each result. [F]
- FZ
- Type: SystemDouble
This array contains the base reaction force in the global Z direction for each result. [F]
- MX
- Type: SystemDouble
This array contains the base reaction moment about the global X axis for each result. [FL]
- ParamMy
- Type: SystemDouble
This array contains the base reaction moment about the global Y axis for each result. [FL]
- MZ
- Type: SystemDouble
This array contains the base reaction moment about the global Z axis for each result. [FL]
- GX
- Type: SystemDouble
The global X coordinate of the point at which the base reactions are reported. [L]
- GY
- Type: SystemDouble
The global Y coordinate of the point at which the base reactions are reported. [L]
- GZ
- Type: SystemDouble
The global Z coordinate of the point at which the base reactions are reported. [L]
Return Value
Type:
Int32
Returns zero if the reactions are successfully recovered, otherwise it returns a nonzero value
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim NumberResults As Integer
Dim LoadCase() As String
Dim StepType() As String
Dim StepNum() As Double
Dim Fx() As Double
Dim Fy() As Double
Dim Fz() As Double
Dim Mx() As Double
Dim ParamMy() As Double
Dim Mz() As Double
Dim gx as Double
Dim gy as Double
Dim gz as Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
System.IO.Directory.CreateDirectory("c:\CSI_API_temp")
ret = SapModel.File.Save("C:\CSI_API_temp\example.edb")
ret = SapModel.Analyze.RunAnalysis()
ret = SapModel.Results.Setup.DeselectAllCasesAndCombosForOutput()
ret = SapModel.Results.Setup.SetCaseSelectedForOutput("DEAD")
ret = SapModel.Results.BaseReact(NumberResults, LoadCase, StepType, StepNum, Fx, Fy, Fz, Mx, ParamMy, Mz, gx, gy, gz)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also