cPropFrameSetGeneral Method |
Initializes a general frame section property. If this function is called for an existing
frame section property, all items for the section are reset to their default value.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetGeneral(
string Name,
string MatProp,
double T3,
double T2,
double Area,
double As2,
double As3,
double Torsion,
double I22,
double I33,
double S22,
double S33,
double Z22,
double Z33,
double R22,
double R33,
int Color = -1,
string Notes = "",
string GUID = ""
)
Function SetGeneral (
Name As String,
MatProp As String,
T3 As Double,
T2 As Double,
Area As Double,
As2 As Double,
As3 As Double,
Torsion As Double,
I22 As Double,
I33 As Double,
S22 As Double,
S33 As Double,
Z22 As Double,
Z33 As Double,
R22 As Double,
R33 As Double,
Optional Color As Integer = -1,
Optional Notes As String = "",
Optional GUID As String = ""
) As Integer
int SetGeneral(
String^ Name,
String^ MatProp,
double T3,
double T2,
double Area,
double As2,
double As3,
double Torsion,
double I22,
double I33,
double S22,
double S33,
double Z22,
double Z33,
double R22,
double R33,
int Color = -1,
String^ Notes = L"",
String^ GUID = L""
)
abstract SetGeneral :
Name : string *
MatProp : string *
T3 : float *
T2 : float *
Area : float *
As2 : float *
As3 : float *
Torsion : float *
I22 : float *
I33 : float *
S22 : float *
S33 : float *
Z22 : float *
Z33 : float *
R22 : float *
R33 : float *
?Color : int *
?Notes : string *
?GUID : string
(* Defaults:
let _Color = defaultArg Color -1
let _Notes = defaultArg Notes ""
let _GUID = defaultArg GUID ""
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing or new frame section property.
If this is an existing property, that property is modified; otherwise, a new property is added. - MatProp
- Type: SystemString
The name of the material property for the section. - T3
- Type: SystemDouble
- T2
- Type: SystemDouble
- Area
- Type: SystemDouble
The cross-sectional area. [L2] - As2
- Type: SystemDouble
The shear area for forces in the section local 2-axis direction. [L2] - As3
- Type: SystemDouble
The shear area for forces in the section local 3-axis direction. [L2] - Torsion
- Type: SystemDouble
The torsional constant. [L4] - I22
- Type: SystemDouble
The moment of inertia for bending about the local 2 axis. [L4] - I33
- Type: SystemDouble
The moment of inertia for bending about the local 3 axis. [L4] - S22
- Type: SystemDouble
The section modulus for bending about the local 2 axis. [L3] - S33
- Type: SystemDouble
The section modulus for bending about the local 3 axis. [L3] - Z22
- Type: SystemDouble
The plastic modulus for bending about the local 2 axis. [L3] - Z33
- Type: SystemDouble
The plastic modulus for bending about the local 3 axis. [L3] - R22
- Type: SystemDouble
The radius of gyration about the local 2 axis. [L] - R33
- Type: SystemDouble
The radius of gyration about the local 3 axis. [L] - Color (Optional)
- Type: SystemInt32
- Notes (Optional)
- Type: SystemString
- GUID (Optional)
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the section.
If this item is input as Default, the program assigns a GUID to the section.
Return Value
Type:
Int32Returns zero if the section property is successfully initialized;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.SetGeneral("GEN1", "A992Fy50", 24, 14, 100, 80, 80, 4, 1000, 2400, 140, 200, 150, 220, 3, 5, -1, "API example", "Default")
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also