cPointObjDeleteLoadDispl Method

Deletes all ground displacement load assignments, for the specified load pattern, from the specified point object(s).

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int DeleteLoadDispl(
	string Name,
	string LoadPat,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: SystemString
The name of an existing point object or group depending on the value of the ItemType item.
LoadPat
Type: SystemString
The name of the load pattern for the ground displacement load.
ItemType (Optional)
Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If Objects is selected, the Name item refers to a point object. The load assignments, for the specified load pattern, made to that point object, are removed.

If Group is selected, the Name item refers to a group. The load assignments, for the specified load pattern, made to all point objects in the group, are removed.

If SelectedObjects is selected, the Name item is ignored. The load assignments, for the specified load pattern, made to all selected point objects, are removed.

Return Value

Type: Int32
Returns zero if the load assignments are successfully deleted, otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim Value as Double()

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

   'add ground displacement load
       Redim Value(5)
       Value(0) = 10
       ret = SapModel.PointObj.SetLoadDispl("1", "DEAD", Value)

   'delete ground displacement load
       ret = SapModel.PointObj.DeleteLoadDispl("1", "DEAD")

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also