cFrameObjGetSection Method |
Retrieves the frame section property assigned to a frame object.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetSection(
string Name,
ref string PropName,
ref string SAuto
)
Function GetSection (
Name As String,
ByRef PropName As String,
ByRef SAuto As String
) As Integer
int GetSection(
String^ Name,
String^% PropName,
String^% SAuto
)
abstract GetSection :
Name : string *
PropName : string byref *
SAuto : string byref -> int
Parameters
- Name
- Type: SystemString
The name of a defined frame object.
- PropName
- Type: SystemString
If no auto select list is assigned to the frame object,
this is the name of the frame section property assigned
to the frame object. If an auto select list is assigned
to the frame object, this is the name of the frame section
property, within the auto select list, which is currently
being used as the analysis property for the frame object.
If this item is None, no frame section property is assigned
to the frame object.
- SAuto
- Type: SystemString
This is the name of the auto select list assigned
to the frame object, if any. If this item is returned
as a blank string, no auto select list is assigned
to the frame object.
Return Value
Type:
Int32
Returns zero if the frame object property is successfully retrieved,
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim PropName As String
Dim SAuto As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj.GetSection("3", PropName, SAuto)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also