cPointObjGetLoadDispl Method |
Retrieves the ground displacement load assignments to point objects.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetLoadDispl(
string Name,
ref int NumberItems,
ref string[] PointName,
ref string[] LoadPat,
ref int[] LcStep,
ref string[] CSys,
ref double[] U1,
ref double[] U2,
ref double[] U3,
ref double[] R1,
ref double[] R2,
ref double[] R3,
eItemType ItemType = eItemType.Objects
)
Function GetLoadDispl (
Name As String,
ByRef NumberItems As Integer,
ByRef PointName As String(),
ByRef LoadPat As String(),
ByRef LcStep As Integer(),
ByRef CSys As String(),
ByRef U1 As Double(),
ByRef U2 As Double(),
ByRef U3 As Double(),
ByRef R1 As Double(),
ByRef R2 As Double(),
ByRef R3 As Double(),
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int GetLoadDispl(
String^ Name,
int% NumberItems,
array<String^>^% PointName,
array<String^>^% LoadPat,
array<int>^% LcStep,
array<String^>^% CSys,
array<double>^% U1,
array<double>^% U2,
array<double>^% U3,
array<double>^% R1,
array<double>^% R2,
array<double>^% R3,
eItemType ItemType = eItemType::Objects
)
abstract GetLoadDispl :
Name : string *
NumberItems : int byref *
PointName : string[] byref *
LoadPat : string[] byref *
LcStep : int[] byref *
CSys : string[] byref *
U1 : float[] byref *
U2 : float[] byref *
U3 : float[] byref *
R1 : float[] byref *
R2 : float[] byref *
R3 : float[] byref *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing point object or group depending on the
value of the ItemType item.
- NumberItems
- Type: SystemInt32
This is the total number of joint ground displacement assignments returned.
- PointName
- Type: SystemString
This is an array that includes the name of the point object to which
the specified ground displacement assignment applies.
- LoadPat
- Type: SystemString
This is an array that includes the name of the load pattern for
the ground displacement load.
- LcStep
- Type: SystemInt32
- CSys
- Type: SystemString
This is an array that includes the name of the coordinate system
for the ground displacement load. This is Local or
the name of a defined coordinate system.
- U1
- Type: SystemDouble
This is an array that includes the assigned translational ground displacement
in the local 1-axis or coordinate system X-axis direction,
depending on the specified CSys. [L]
- U2
- Type: SystemDouble
This is an array that includes the assigned translational ground displacement
in the local 2-axis or coordinate system Y-axis direction,
depending on the specified CSys. [L]
- U3
- Type: SystemDouble
- R1
- Type: SystemDouble
This is an array that includes the assigned rotational ground displacement
about the local 1-axis or coordinate system X-axis,
depending on the specified CSys. [rad]
- R2
- Type: SystemDouble
This is an array that includes the assigned rotational ground displacement
about the local 2-axis or coordinate system Y-axis,
depending on the specified CSys. [rad]
- R3
- Type: SystemDouble
This is an array that includes the assigned rotational ground displacement
about the local 3-axis or coordinate system Z-axis,
depending on the specified CSys. [rad]
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the load assignments are retrieved for the point object
specified by the Name item.
If this item is Group, the load assignments are retrieved for all point objects
in the group specified by the Name item.
If this item is SelectedObjects, the load assignments are retrieved for all
selected point objects and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the load assignments are successfully retrieved,
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim NumberItems As Long
Dim PointName() As String
Dim LoadPat() As String
Dim LCStep() As Long
Dim CSys() As String
Dim U1() As Double
Dim U2() As Double
Dim U3() As Double
Dim R1() As Double
Dim R2() As Double
Dim R3() As Double
Dim Value() As Double
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
Redim Value(5)
Value(0) = 10
ret = SapModel.PointObj.SetLoadDispl("1", "DEAD", Value)
ret = SapModel.PointObj.GetLoadDispl("ALL", NumberItems, PointName, LoadPat, LCStep, CSys, U1, U2, U3, R1, R2, R3, eItemType.Group)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also