cGridSysSetGridSys Method |
Adds a new grid system, or modifies an existing grid system.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetGridSys(
string Name,
double x,
double y,
double RZ
)
Function SetGridSys (
Name As String,
x As Double,
y As Double,
RZ As Double
) As Integer
int SetGridSys(
String^ Name,
double x,
double y,
double RZ
)
abstract SetGridSys :
Name : string *
x : float *
y : float *
RZ : float -> int
Parameters
- Name
- Type: SystemString
This is the name of a grid system. If this is the name
of an existing grid system, that grid system is modified,
otherwise a new grid system is added.
- x
- Type: SystemDouble
The global X grid of the origin of the grid system. [L]
- y
- Type: SystemDouble
The global Y grid of the origin of the grid system. [L]
- RZ
- Type: SystemDouble
The rotation of an axis of the new grid system relative to the
global grid system is defined as follows:
(1) Rotate the grid system about the positive global Z-axis
as defined by the RZ item. [deg]
Return Value
Type:
Int32
Returns zero if the grid system is successfully added or modified,
otherwise it returns a nonzero value.
Remarks
Modifying the Global grid system will fail and return an error.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.GridSys.SetGridSys("GridSysA", 1000, 1000, 0, 0)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also