cPropFrameGetNameInPropFile Method |
Retrieves the names of the section property file from which an
imported frame section originated, and it also retrieves
the section name used in the property file.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetNameInPropFile(
string Name,
ref string NameInFile,
ref string FileName,
ref string MatProp,
ref eFramePropType PropType
)
Function GetNameInPropFile (
Name As String,
ByRef NameInFile As String,
ByRef FileName As String,
ByRef MatProp As String,
ByRef PropType As eFramePropType
) As Integer
int GetNameInPropFile(
String^ Name,
String^% NameInFile,
String^% FileName,
String^% MatProp,
eFramePropType% PropType
)
abstract GetNameInPropFile :
Name : string *
NameInFile : string byref *
FileName : string byref *
MatProp : string byref *
PropType : eFramePropType byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame section property.
- NameInFile
- Type: SystemString
The name of the specified frame section property
in the frame section property file.
- FileName
- Type: SystemString
The name of the frame section property file from which the specified frame
section property was obtained.
- MatProp
- Type: SystemString
The name of the material property for the section.
- PropType
- Type: ETABS2016eFramePropType
This is one of the items in the eFramePropType enumeration.
Return Value
Type:
Int32
Returns zero if the names are successfully retrieved;
otherwise it returns nonzero.
Remarks
If the specified frame section property was not imported, blank strings
are returned for
NameInFile and
FileName.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim NameInFile As String
Dim FileName As String
Dim MatProp As String
Dim PropType As eFramePropType
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.ImportProp("MyFrame", "A992Fy50", "Sections8.pro", "W18X35")
ret = SapModel.PropFrame.GetNameInPropFile("MyFrame", NameInFile, FileName, MatProp, PropType)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also