cPropFrameGetTypeRebar Method |
Retrieves the rebar design type for the specified frame section property
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetTypeRebar(
string Name,
ref int MyType
)
Function GetTypeRebar (
Name As String,
ByRef MyType As Integer
) As Integer
int GetTypeRebar(
String^ Name,
int% MyType
)
abstract GetTypeRebar :
Name : string *
MyType : int byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame section property
- MyType
- Type: SystemInt32
This is 0, 1 or 2, indicating the rebar design type.
Return Value
Type:
Int32
Returns zero if the type is successfully retrieved; otherwise it returns nonzero
Remarks
This function applies only to the following section property types.
Calling this function for any other type of frame section property returns an error.
- Concrete Tee
- Concrete Angle
- Concrete Rectangle
- Concrete Circle
A nonzero rebar type is returned only if the frame section property has a concrete material.
See Also