cLoadPatternsGetSelfWTMultiplier Method

Retrieves the self weight multiplier for a specified load pattern.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetSelfWTMultiplier(
	string Name,
	ref double SelfWTMultiplier
)

Parameters

Name
Type: SystemString
The name of an existing load pattern.
SelfWTMultiplier
Type: SystemDouble
The self weight multiplier for the specified load pattern.

Return Value

Type: Int32
Returns zero if the multiplier is successfully retrieved; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim SelfWTMultiplier As Double

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'get self weight multiplier
       ret = SapModel.LoadPatterns.GetSelfWtMultiplier("DEAD", SelfWTMultiplier)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also