cPropFrameGetGeneral Method |
Retrieves frame section property data for a general frame section
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetGeneral(
string Name,
ref string FileName,
ref string MatProp,
ref double T3,
ref double T2,
ref double Area,
ref double As2,
ref double As3,
ref double Torsion,
ref double I22,
ref double I33,
ref double S22,
ref double S33,
ref double Z22,
ref double Z33,
ref double R22,
ref double R33,
ref int Color,
ref string Notes,
ref string GUID
)
Function GetGeneral (
Name As String,
ByRef FileName As String,
ByRef MatProp As String,
ByRef T3 As Double,
ByRef T2 As Double,
ByRef Area As Double,
ByRef As2 As Double,
ByRef As3 As Double,
ByRef Torsion As Double,
ByRef I22 As Double,
ByRef I33 As Double,
ByRef S22 As Double,
ByRef S33 As Double,
ByRef Z22 As Double,
ByRef Z33 As Double,
ByRef R22 As Double,
ByRef R33 As Double,
ByRef Color As Integer,
ByRef Notes As String,
ByRef GUID As String
) As Integer
int GetGeneral(
String^ Name,
String^% FileName,
String^% MatProp,
double% T3,
double% T2,
double% Area,
double% As2,
double% As3,
double% Torsion,
double% I22,
double% I33,
double% S22,
double% S33,
double% Z22,
double% Z33,
double% R22,
double% R33,
int% Color,
String^% Notes,
String^% GUID
)
abstract GetGeneral :
Name : string *
FileName : string byref *
MatProp : string byref *
T3 : float byref *
T2 : float byref *
Area : float byref *
As2 : float byref *
As3 : float byref *
Torsion : float byref *
I22 : float byref *
I33 : float byref *
S22 : float byref *
S33 : float byref *
Z22 : float byref *
Z33 : float byref *
R22 : float byref *
R33 : float byref *
Color : int byref *
Notes : string byref *
GUID : string byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame section property. - FileName
- Type: SystemString
If the section property was imported from a property file,
this is the name of that file. If the section property was not imported, this item is blank. - MatProp
- Type: SystemString
The name of the material property for the section. - T3
- Type: SystemDouble
- T2
- Type: SystemDouble
- Area
- Type: SystemDouble
The cross-sectional area. [L2] - As2
- Type: SystemDouble
The shear area for forces in the section local 2-axis direction. [L2] - As3
- Type: SystemDouble
The shear area for forces in the section local 3-axis direction. [L2] - Torsion
- Type: SystemDouble
The torsional constant. [L4] - I22
- Type: SystemDouble
The moment of inertia for bending about the local 2 axis. [L4] - I33
- Type: SystemDouble
The moment of inertia for bending about the local 3 axis. [L4] - S22
- Type: SystemDouble
The section modulus for bending about the local 2 axis. [L3] - S33
- Type: SystemDouble
The section modulus for bending about the local 3 axis. [L3] - Z22
- Type: SystemDouble
The plastic modulus for bending about the local 2 axis. [L3] - Z33
- Type: SystemDouble
The plastic modulus for bending about the local 3 axis. [L3] - R22
- Type: SystemDouble
The radius of gyration about the local 2 axis. [L] - R33
- Type: SystemDouble
The radius of gyration about the local 3 axis. [L] - Color
- Type: SystemInt32
- Notes
- Type: SystemString
- GUID
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the section.
Return Value
Type:
Int32Returns zero if the section property data is successfully retrieved;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim FileName As String
Dim MatProp As String
Dim t3 As Double
Dim t2 As Double
Dim Area As Double
Dim as2 As Double
Dim as3 As Double
Dim Torsion As Double
Dim I22 As Double
Dim I33 As Double
Dim S22 As Double
Dim S33 As Double
Dim Z22 As Double
Dim Z33 As Double
Dim R22 As Double
Dim R33 As Double
Dim Color As Integer
Dim Notes As String
Dim GUID As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.SetGeneral("GEN1", "A992Fy50", 24, 14, 100, 80, 80, 4, 1000, 2400, 140, 200, 150, 220, 3, 5, -1, "API example", "Default")
ret = SapModel.PropFrame.GetGeneral("GEN1", FileName, MatProp, t3, t2, Area, As2, As3, Torsion, I22, I33, S22, S33, Z22, Z33, R22, R33, Color, Notes, GUID)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also