initializes a solid rod frame section property.If this function is called for an existing
frame section property, all items for the section are reset to their default value.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetRod(
string Name,
string MatProp,
double T3,
int Color = -1,
string Notes = "",
string GUID = ""
)
Function SetRod (
Name As String,
MatProp As String,
T3 As Double,
Optional Color As Integer = -1,
Optional Notes As String = "",
Optional GUID As String = ""
) As Integer
int SetRod(
String^ Name,
String^ MatProp,
double T3,
int Color = -1,
String^ Notes = L"",
String^ GUID = L""
)
abstract SetRod :
Name : string *
MatProp : string *
T3 : float *
?Color : int *
?Notes : string *
?GUID : string
(* Defaults:
let _Color = defaultArg Color -1
let _Notes = defaultArg Notes ""
let _GUID = defaultArg GUID ""
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing or new frame section property.
If this is an existing property, that property is modified; otherwise, a new property is added. - MatProp
- Type: SystemString
The name of the material property for the section. - T3
- Type: SystemDouble
- Color (Optional)
- Type: SystemInt32
- Notes (Optional)
- Type: SystemString
- GUID (Optional)
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the section.
If this item is input as Default, the program assigns a GUID to the section.
Return Value
Type:
Int32Returns zero if the section property is successfully initialized;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.SetRod("R1", "A992Fy50", 20)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also