cFrameObjGetSupports Method |
Retrieves support data for a given frame beam object
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetSupports(
string Name,
ref string SupportName1,
ref eObjType SupportType1,
ref string SupportName2,
ref eObjType SupportType2
)
Function GetSupports (
Name As String,
ByRef SupportName1 As String,
ByRef SupportType1 As eObjType,
ByRef SupportName2 As String,
ByRef SupportType2 As eObjType
) As Integer
int GetSupports(
String^ Name,
String^% SupportName1,
eObjType% SupportType1,
String^% SupportName2,
eObjType% SupportType2
)
abstract GetSupports :
Name : string *
SupportName1 : string byref *
SupportType1 : eObjType byref *
SupportName2 : string byref *
SupportType2 : eObjType byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame beam object - SupportName1
- Type: SystemString
The name of the column frame object, beam frame object or wall area object which supports the beam at its start node - SupportType1
- Type: ETABS2016eObjType
A value from the eObjType enumeration - SupportName2
- Type: SystemString
The name of the column frame object, beam frame object or wall area object which supports the beam at its end node - SupportType2
- Type: ETABS2016eObjType
A value from the eObjType enumeration
Return Value
Type:
Int32
Remarks
See Also