cComboGetCaseList Method

Retrieves all load cases and response combinations included in the load combination specified by the Name item.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetCaseList(
	string Name,
	ref int NumberItems,
	ref eCNameType[] CNameType,
	ref string[] CName,
	ref double[] SF
)

Parameters

Name
Type: SystemString
The name of an existing load combination.
NumberItems
Type: SystemInt32
The total number of load cases and load combinations included in the load combination specified by the Name item.
CNameType
Type: ETABS2016eCNameType
This is one of the following items in the eCNameType enumeration:
  • LoadCase = 0
  • LoadCombo = 1

This item indicates whether the CName item is an analysis case (LoadCase) or a load combination (LoadCombo).

CName
Type: SystemString
This is an array of the names of the load cases or load combinations included in the load combination specified by the Name item.
SF
Type: SystemDouble

Return Value

Type: Int32
Returns zero if the data is successfully retrieved, otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim NumberItems As Integer
       Dim CNameType() As eCNameType
       Dim CName() As String
       Dim SF() As Double

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add combo
       ret = SapModel.RespCombo.Add("COMB1", 0)

   'add load case to combo
       ret = SapModel.RespCombo.SetCaseList("COMB1", LoadCase, "DEAD", 1.4)

   'get all cases and combos included in combo COMB1
       ret = SapModel.RespCombo.GetCaseList("COMB1", NumberItems, CNameType, CName, SF)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also