cAnalyzeSetRunCaseFlag Method

Sets the run flag for load cases.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetRunCaseFlag(
	string Name,
	bool Run,
	bool All = false
)

Parameters

Name
Type: SystemString
The name of an existing load case that is to have its run flag set.

This item is ignored when the All item is True.

Run
Type: SystemBoolean
If this item is True, the specified load case is to be run.
All (Optional)
Type: SystemBoolean
If this item is True, the run flag is set as specified by the Run item for all load cases, and the Name item is ignored.

Return Value

Type: Int32
Returns zero if the flag is successfully set; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'set load case run flag
       ret = SapModel.Analyze.SetRunCaseFlag("MODAL", False)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also