cPropFrameSDShapeGetReinfSingle Method |
Retrieves property data for a single bar reinforcing shape in a section designer section
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetReinfSingle(
string Name,
string ShapeName,
ref double XCenter,
ref double YCenter,
ref string RebarSize,
ref string MatRebar
)
Function GetReinfSingle (
Name As String,
ShapeName As String,
ByRef XCenter As Double,
ByRef YCenter As Double,
ByRef RebarSize As String,
ByRef MatRebar As String
) As Integer
int GetReinfSingle(
String^ Name,
String^ ShapeName,
double% XCenter,
double% YCenter,
String^% RebarSize,
String^% MatRebar
)
abstract GetReinfSingle :
Name : string *
ShapeName : string *
XCenter : float byref *
YCenter : float byref *
RebarSize : string byref *
MatRebar : string byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame section property that is a section designer section
- ShapeName
- Type: SystemString
The name of a single bar reinforcing shape in the section designer section
- XCenter
- Type: SystemDouble
The X-coordinate of the center of the shape in the section designer coordinate system. [L]
- YCenter
- Type: SystemDouble
The Y-coordinate of the center of the shape in the section designer coordinate system. [L]
- RebarSize
- Type: SystemString
The size of the reinforcing bar
- MatRebar
- Type: SystemString
The material property for the reinforcing steel
Return Value
Type:
Int32
Returns zero if the property data is successfully retrieved; otherwise it returns a nonzero value
Remarks
See Also