cPropFrameGetRebarColumn Method |
Retrieves column rebar data for frame sections.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetRebarColumn(
string Name,
ref string MatPropLong,
ref string MatPropConfine,
ref int Pattern,
ref int ConfineType,
ref double Cover,
ref int NumberCBars,
ref int NumberR3Bars,
ref int NumberR2Bars,
ref string RebarSize,
ref string TieSize,
ref double TieSpacingLongit,
ref int Number2DirTieBars,
ref int Number3DirTieBars,
ref bool ToBeDesigned
)
Function GetRebarColumn (
Name As String,
ByRef MatPropLong As String,
ByRef MatPropConfine As String,
ByRef Pattern As Integer,
ByRef ConfineType As Integer,
ByRef Cover As Double,
ByRef NumberCBars As Integer,
ByRef NumberR3Bars As Integer,
ByRef NumberR2Bars As Integer,
ByRef RebarSize As String,
ByRef TieSize As String,
ByRef TieSpacingLongit As Double,
ByRef Number2DirTieBars As Integer,
ByRef Number3DirTieBars As Integer,
ByRef ToBeDesigned As Boolean
) As Integer
int GetRebarColumn(
String^ Name,
String^% MatPropLong,
String^% MatPropConfine,
int% Pattern,
int% ConfineType,
double% Cover,
int% NumberCBars,
int% NumberR3Bars,
int% NumberR2Bars,
String^% RebarSize,
String^% TieSize,
double% TieSpacingLongit,
int% Number2DirTieBars,
int% Number3DirTieBars,
bool% ToBeDesigned
)
abstract GetRebarColumn :
Name : string *
MatPropLong : string byref *
MatPropConfine : string byref *
Pattern : int byref *
ConfineType : int byref *
Cover : float byref *
NumberCBars : int byref *
NumberR3Bars : int byref *
NumberR2Bars : int byref *
RebarSize : string byref *
TieSize : string byref *
TieSpacingLongit : float byref *
Number2DirTieBars : int byref *
Number3DirTieBars : int byref *
ToBeDesigned : bool byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame section property. - MatPropLong
- Type: SystemString
The name of the rebar material property for the longitudinal rebar. - MatPropConfine
- Type: SystemString
The name of the rebar material property for the confinement rebar. - Pattern
- Type: SystemInt32
This is either 1 or 2, indicating the rebar configuration.
Value | Pattern |
---|
1 | Rectangular |
2 | Circular |
For circular frame section properties this item must be 2; otherwise an error is returned.
- ConfineType
- Type: SystemInt32
This is either 1 or 2, indicating the confinement bar type.
This item applies only when Pattern = 2.
If Pattern = 1, the confinement bar type is assumed to be ties.
- Cover
- Type: SystemDouble
The clear cover for the confinement steel (ties).
In the special case of circular reinforcement in a rectangular column,
this is the minimum clear cover. [L] - NumberCBars
- Type: SystemInt32
This item applies to a circular rebar configuration, Pattern = 2.
It is the total number of longitudinal reinforcing bars in the column. - NumberR3Bars
- Type: SystemInt32
This item applies to a rectangular rebar configuration, Pattern = 1.
It is the number of longitudinal bars (including the corner bar) on each face of the column
that is parallel to the local 3-axis of the column. - NumberR2Bars
- Type: SystemInt32
This item applies to a rectangular rebar configuration, Pattern = 1.
It is the number of longitudinal bars (including the corner bar) on each face of the column
that is parallel to the local 2-axis of the column. - RebarSize
- Type: SystemString
The rebar name for the longitudinal rebar in the column. - TieSize
- Type: SystemString
The rebar name for the confinement rebar in the column. - TieSpacingLongit
- Type: SystemDouble
The longitudinal spacing of the confinement bars (ties). [L] - Number2DirTieBars
- Type: SystemInt32
This item applies to a rectangular reinforcing configuration,
Pattern = 1. It is the number of confinement bars (tie legs) running in the
local 2-axis direction of the column. - Number3DirTieBars
- Type: SystemInt32
This item applies to a rectangular reinforcing configuration,
Pattern = 1. It is the number of confinement bars (tie legs) running in the
local 3-axis direction of the column. - ToBeDesigned
- Type: SystemBoolean
If this item is True, the column longitudinal rebar is to be designed;
otherwise it is to be checked.
Return Value
Type:
Int32Returns zero if the rebar data is successfully retrieved;
otherwise it returns a nonzero value.
Remarks
This function applies only to the following section types. Calling this function for any other type of frame section property returns an error.
The material assigned to the specified frame section property must be concrete or this function returns an error.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim RebarName As String
Dim MatPropLong As String
Dim MatPropConfine As String
Dim Pattern As Integer
Dim ConfineType As Integer
Dim Cover As Double
Dim NumberCBars As Integer
Dim NumberR3Bars As Integer
Dim NumberR2Bars As Integer
Dim RebarSize As String
Dim TieSize As String
Dim TieSpacingLongit As Double
Dim Number2DirTieBars As Integer
Dim Number3DirTieBars As Integer
Dim ToBeDesigned As Boolean
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.SetRectangle("R1", "4000Psi", 20, 12)
ret = SapModel.PropMaterial.AddQuick(RebarName, eMatType.Rebar, , , , , eMatTypeRebar.ASTM_A706)
ret = SapModel.PropFrame.SetRebarColumn("R1", RebarName, RebarName, 2, 2, 2, 10, 0, 0, "#10", "#5", 4, 0, 0, False)
ret = SapModel.PropFrame.GetRebarColumn("R1", MatPropLong, MatPropConfine, Pattern, ConfineType, Cover, NumberCBars, NumberR3Bars, NumberR2Bars, RebarSize, TieSize, TieSpacingLongit, Number2DirTieBars, Number3DirTieBars, ToBeDesigned)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also