cPropAreaGetShellLayer_1 Method |
Retrieves area property layer parameters for a shell-type area section.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetShellLayer_1(
string Name,
ref int NumberLayers,
ref string[] LayerName,
ref double[] Dist,
ref double[] Thickness,
ref int[] MyType,
ref int[] NumIntegrationPts,
ref string[] MatProp,
ref double[] MatAng,
ref int[] S11Type,
ref int[] S22Type,
ref int[] S12Type
)
Function GetShellLayer_1 (
Name As String,
ByRef NumberLayers As Integer,
ByRef LayerName As String(),
ByRef Dist As Double(),
ByRef Thickness As Double(),
ByRef MyType As Integer(),
ByRef NumIntegrationPts As Integer(),
ByRef MatProp As String(),
ByRef MatAng As Double(),
ByRef S11Type As Integer(),
ByRef S22Type As Integer(),
ByRef S12Type As Integer()
) As Integer
int GetShellLayer_1(
String^ Name,
int% NumberLayers,
array<String^>^% LayerName,
array<double>^% Dist,
array<double>^% Thickness,
array<int>^% MyType,
array<int>^% NumIntegrationPts,
array<String^>^% MatProp,
array<double>^% MatAng,
array<int>^% S11Type,
array<int>^% S22Type,
array<int>^% S12Type
)
abstract GetShellLayer_1 :
Name : string *
NumberLayers : int byref *
LayerName : string[] byref *
Dist : float[] byref *
Thickness : float[] byref *
MyType : int[] byref *
NumIntegrationPts : int[] byref *
MatProp : string[] byref *
MatAng : float[] byref *
S11Type : int[] byref *
S22Type : int[] byref *
S12Type : int[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing shell-type area property that is specified to be a
layered shell property. - NumberLayers
- Type: SystemInt32
The number of layers in the area property. - LayerName
- Type: SystemString
This is an array that includes the name of each layer. - Dist
- Type: SystemDouble
- Thickness
- Type: SystemDouble
This is an array that includes the thickness of each layer. [L] - MyType
- Type: SystemInt32
This is an array that includes 1, 2 or 3, indicating the layer type.
Value | Type |
---|
1 | Shell |
2 | Membrane |
3 | Plate |
- NumIntegrationPts
- Type: SystemInt32
The number of integration points in the thickness direction for the layer.
The locations are determined by the program using standard Guass-quadrature rules. - MatProp
- Type: SystemString
This is an array that includes the name of the material property for the layer. - MatAng
- Type: SystemDouble
- S11Type
- Type: SystemInt32
This is an array that includes 0, 1 or 2, indicating the material component behavior.
Value | S11Type |
---|
0 | Inactive |
1 | Linear |
2 | Nonlinear |
- S22Type
- Type: SystemInt32
This is an array that includes 0, 1 or 2, indicating the material component behavior.
Value | S22Type |
---|
0 | Inactive |
1 | Linear |
2 | Nonlinear |
- S12Type
- Type: SystemInt32
This is an array that includes 0, 1 or 2, indicating the material component behavior.
Value | S12Type |
---|
0 | Inactive |
1 | Linear |
2 | Nonlinear |
Return Value
Type:
Int32Returns zero if the parameters are successfully retrieved,
otherwise it returns a nonzero value.
The function returns an error if the specified area property
is not a shell-type property specified to be a layered shell.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
Dim MyNumberLayers As Integer
Dim MyLayerName() As String
Dim MyDist() As Double
Dim MyThickness() As Double
Dim MyType() As Integer
Dim MyNumIntegrationPts() As Integer
Dim MyMatProp() As String
Dim MyMatAng() As Double
Dim MyS11Type() As Integer
Dim MyS22Type() As Integer
Dim MyS12Type() As Integer
Dim NumberLayers As Integer
Dim LayerName() As String
Dim Dist() As Double
Dim Thickness() As Double
Dim SType() As Integer
Dim MatProp() As String
Dim MatAng() As Double
Dim S11Type() As Integer
Dim S22Type() As Integer
Dim S12Type() As Integer
Dim NumIntegrationPts() As Integer
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropArea.SetShell_1("A1", 6, True, "", 0, 0, 0)
ret = SapModel.PropMaterial.AddQuick(Name, eMatType.Rebar, , , , , eMatTypeRebar.ASTM_A615Gr60)
MyNumberLayers = 5
ReDim MyLayerName(MyNumberLayers - 1)
ReDim MyDist(MyNumberLayers - 1)
ReDim MyThickness(MyNumberLayers - 1)
ReDim MyType(MyNumberLayers - 1)
ReDim MyNumIntegrationPts(MyNumberLayers - 1)
ReDim MyMatProp(MyNumberLayers - 1)
ReDim MyMatAng(MyNumberLayers - 1)
ReDim MyS11Type(MyNumberLayers - 1)
ReDim MyS22Type(MyNumberLayers - 1)
ReDim MyS12Type(MyNumberLayers - 1)
MyLayerName(0) = "Concrete"
MyDist(0) = 0
MyThickness(0) = 16
MyType(0) = 1
MyNumIntegrationPts(0) = 2
MyMatProp(0) = "4000Psi"
MyMatAng(0) = 0
MyS11Type(0) = 1
MyS22Type(0) = 1
MyS12Type(0) = 1
MyLayerName(1) = "Top Bar 1"
MyDist(1) = 6
MyThickness(1) = 0.03
MyType(1) = 1
MyNumIntegrationPts(1) = 1
MyMatProp(1) = Name
MyMatAng(1) = 0
MyS11Type(1) = 1
MyS22Type(1) = 1
MyS12Type(1) = 1
MyLayerName(2) = "Top Bar 2"
MyDist(2) = 6
MyThickness(2) = 0.03
MyType(2) = 1
MyNumIntegrationPts(2) = 1
MyMatProp(2) = Name
MyMatAng(2) = 90
MyS11Type(1) = 1
MyS22Type(1) = 1
MyS12Type(1) = 1
MyLayerName(3) = "Bot Bar 1"
MyDist(3) = -6
MyThickness(3) = 0.03
MyType(3) = 1
MyNumIntegrationPts(3) = 1
MyMatProp(3) = Name
MyMatAng(3) = 0
MyS11Type(1) = 1
MyS22Type(1) = 1
MyS12Type(1) = 1
MyLayerName(4) = "Bot Bar 2"
MyDist(4) = -6
MyThickness(4) = 0.03
MyType(4) = 1
MyNumIntegrationPts(4) = 1
MyMatProp(4) = Name
MyMatAng(4) = 90
MyS11Type(1) = 1
MyS22Type(1) = 1
MyS12Type(1) = 1
ret = SapModel.PropArea.SetShellLayer_1("A1", MyNumberLayers, MyLayerName, MyDist, MyThickness, MyType, MyNumIntegrationPts, MyMatProp, MyMatAng, MyS11Type, MyS22Type, MyS12Type)
ret = SapModel.PropArea.GetShellLayer_1("A1", NumberLayers, LayerName, Dist, Thickness, Stype, NumIntegrationPts, MatProp, MatAng, S11Type, S22Type, S12Type)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also