cPointObjSetLoadDispl Method |
Makes ground displacement load assignments to point objects.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetLoadDispl(
string Name,
string LoadPat,
ref double[] Value,
bool Replace = false,
string CSys = "Local",
eItemType ItemType = eItemType.Objects
)
Function SetLoadDispl (
Name As String,
LoadPat As String,
ByRef Value As Double(),
Optional Replace As Boolean = false,
Optional CSys As String = "Local",
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int SetLoadDispl(
String^ Name,
String^ LoadPat,
array<double>^% Value,
bool Replace = false,
String^ CSys = L"Local",
eItemType ItemType = eItemType::Objects
)
abstract SetLoadDispl :
Name : string *
LoadPat : string *
Value : float[] byref *
?Replace : bool *
?CSys : string *
?ItemType : eItemType
(* Defaults:
let _Replace = defaultArg Replace false
let _CSys = defaultArg CSys "Local"
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing point object or group depending on the
value of the ItemType item.
- LoadPat
- Type: SystemString
The name of the load pattern for the ground displacement load.
- Value
- Type: SystemDouble
This is an array of six point load values.
- Value(0) = U1 [L]
- Value(1) = U2 [L]
- Value(2) = U3 [L]
- Value(3) = R1 [rad]
- Value(4) = R2 [rad]
- Value(5) = R3 [rad]
- Replace (Optional)
- Type: SystemBoolean
If this item is True, all previous ground displacement loads, if any,
assigned to the specified point object(s) in the specified load
pattern are deleted before making the new assignment.
- CSys (Optional)
- Type: SystemString
The name of the coordinate system for the considered ground displacement load.
This is Local or the name of a defined coordinate system.
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the load assignment is made to the point object
specified by the Name item.
If this item is Group, the load assignment is made to all point objects
in the group specified by the Name item.
If this item is SelectedObjects, the load assignment is made to all
selected point objects and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the load assignments are successfully made,
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Value as Double()
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
Redim Value(5)
Value(0) = 10
ret = SapModel.PointObj.SetLoadDispl("1", "DEAD", Value)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also