cPropFrameSetNonPrismatic Method |
Assigns data to a nonprismatic frame section property.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetNonPrismatic(
string Name,
int NumberItems,
ref string[] StartSec,
ref string[] EndSec,
ref double[] MyLength,
ref int[] MyType,
ref int[] EI33,
ref int[] EI22,
int Color = -1,
string Notes = "",
string GUID = ""
)
Function SetNonPrismatic (
Name As String,
NumberItems As Integer,
ByRef StartSec As String(),
ByRef EndSec As String(),
ByRef MyLength As Double(),
ByRef MyType As Integer(),
ByRef EI33 As Integer(),
ByRef EI22 As Integer(),
Optional Color As Integer = -1,
Optional Notes As String = "",
Optional GUID As String = ""
) As Integer
int SetNonPrismatic(
String^ Name,
int NumberItems,
array<String^>^% StartSec,
array<String^>^% EndSec,
array<double>^% MyLength,
array<int>^% MyType,
array<int>^% EI33,
array<int>^% EI22,
int Color = -1,
String^ Notes = L"",
String^ GUID = L""
)
abstract SetNonPrismatic :
Name : string *
NumberItems : int *
StartSec : string[] byref *
EndSec : string[] byref *
MyLength : float[] byref *
MyType : int[] byref *
EI33 : int[] byref *
EI22 : int[] byref *
?Color : int *
?Notes : string *
?GUID : string
(* Defaults:
let _Color = defaultArg Color -1
let _Notes = defaultArg Notes ""
let _GUID = defaultArg GUID ""
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing or new frame section property.
If this is an existing property, that property is modified; otherwise, a new property is added. - NumberItems
- Type: SystemInt32
The number of segments assigned to the nonprismatic section. - StartSec
- Type: SystemString
This is an array of the names of the frame section properties at the start of each segment.
Auto select lists and nonprismatic sections are not allowed in this array.
- EndSec
- Type: SystemString
This is an array of the names of the frame section properties at the end of each segment.
Auto select lists and nonprismatic sections are not allowed in this array.
- MyLength
- Type: SystemDouble
This is an array that includes the length of each segment.
The length may be variable or absolute as indicated by the MyType item. [L] when length is absolute. - MyType
- Type: SystemInt32
This is an array of either 1 or 2, indicating the length type for each segment:
Value | MyType |
---|
1 | Variable (relative length) |
2 | Absolute |
- EI33
- Type: SystemInt32
This is an array of 1, 2 or 3, indicating the variation type for EI33
in each segment:
Value | EI33 |
---|
1 | Linear |
2 | Parabolic |
2 | Cubic |
- EI22
- Type: SystemInt32
This is an array of 1, 2 or 3, indicating the variation type for EI22
in each segment:
Value | EI22 |
---|
1 | Linear |
2 | Parabolic |
2 | Cubic |
- Color (Optional)
- Type: SystemInt32
- Notes (Optional)
- Type: SystemString
- GUID (Optional)
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the section.
If this item is input as Default, the program assigns a GUID to the section.
Return Value
Type:
Int32Returns zero if the data is successfully filled;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim StartSec() As String
Dim EndSec() As String
Dim Length() As Double
Dim SegType() As Integer
Dim EI33() As Integer
Dim EI22() As Integer
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.SetISection("ISEC1", "A992Fy50", 24, 10, 0.5, 0.3, 14, 0.6)
ret = SapModel.PropFrame.SetISection("ISEC2", "A992Fy50", 36, 15, 1, 0.5, 121, 0.9)
ReDim StartSec(2)
ReDim EndSec(2)
ReDim Length(2)
ReDim SegType(2)
ReDim EI33(2)
ReDim EI22(2)
StartSec(0) = "ISEC2"
EndSec(0) = "ISEC1"
Length(0) = 60
SegType(0) = 2
EI33(0)= 2
EI22(0)= 1
StartSec(1) = "ISEC1"
EndSec(1) = "ISEC1"
Length(1) = 1
SegType(1) = 1
EI33(1)= 2
EI22(1)= 1
StartSec(2) = "ISEC1"
EndSec(2) = "ISEC2"
Length(2) = 60
SegType(2) = 2
EI33(2)= 2
EI22(2)= 1
ret = SapModel.PropFrame.SetNonPrismatic("NP1", 3, StartSec, EndSec, Length, SegType, EI33, EI22)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also